Increase your income with Hive. Invite your friends and earn real cryptocurrency!

RX5700XT card was not showing sensors info

Hello miners,
Does anyone haves problem like this on the picture bellow.

This morning the problem appear with one my card at 4 5700xt cards rig.
Last night i do selfupgrade, apt update and apt dist-upgrade on all my rigs. Only rig with 5700xt cards have this issue.
I do some troubleshooting and check following

  • check risers on all cards
  • check PSU
  • check cables and connectors
    and everything looks good to me
    i try to figured out what is problem and do checking cards one by one till other cards was detached completely from rig. ALL cards starting and mining well with around 55mhs just as worked before incident.
    BUT when i connect two card, any combination, or three cards or all 4 cards, one card , specifically card which are at current setup at first position don’t show sensors at HiveOS nor at miner console but still mining with lower hash rate.
    I am thinking first that miner is the problem and i try to choose some older version but i get the same error and issue - using Phoenix miner
    Also, i notice that card with red cross that is always card which is in the current setup at first position (miner shows it as GPU1) gives around 4mhs less then others, around 50mhs
    I try also
  • to switch risers between cards - issue persist
  • try to switch card position - issue persist
  • try to use brand new riser - issue persist
    My conclusion is that cards are not damaged, risers are good and not damaged also.
    I doubt that power supply unit maybe faulty - what is the best way to check it ?!?
    Also i doubt that software maybe cause problem - maybe latest version of HiveOS or drivers or something at linux system
    I appreciate if anyone can help. Any opinion will help.


what is your card? Do you have box & sticker?

if you want contact me telegram @kenshinji59

Red Devil

Do you have try reload Stock Bios?

No. Not yet.
I think that bios isn’t a problem here, because all 4 cards works more than 6 months with this bios.
Bios wasn’t changed now that is why i don’t suspect on bios.
As i wrote at first post only thing that was changed is version of hiveOS from 210712 to 210715 and linux distro upgrade (if i remember correctly 116 items was updated - commands apt udpate && apt dist-upgrade).
No hardware changes before the issue appear neither changes to OC, UV, miner settings.
Firstly i suspect that card was damaged or PSU problem (PSU itself, output line, wire or connector) but after careful inspection and testing i conclude that only two things may be the problem:

  • PSU - i don’t have redundant PSU to check
  • software , hiveOS new version or linux update
    Any similar experience anyone.

After carful inspection and testing hardware issue still exist.

as you can see at pictures any card (i rotate them) which is on position 1 don’t show sensors and mine with about 4 mhs less
i check for new version and do again selfupgrade, update and dist-upgrade to the newest version of HiveOS (version 0.6-205 210719)
But problem is still there.
Than I decide to check rig with older version hiveOS and linux.
i put older version H 0.6-204 210704 at USB flash memory copy all config from ssd and start rig.
HURA !!! I get all my card up and running without issues. As you can see at pics bellow.


Driver version is the same.
Hardware without changes.
CONCLUSION: HiveOS version and linux update cause this problem.
I will stay at current working version till i hear, read or find how to deal with this issue.

1 Like

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.