Increase your income with Hive. Invite your friends and earn real cryptocurrency!

RX5700 XT Nitro+ working on 16x slot but not working with any riser


Yesterday I was moving one of my Nitro+ from one rig to another. When I put it to new rig it stopped responding. I tried everything and saw that it is working only with Pci 16x slot now.

What can be the reason of not working with a riser but working with 16x slot?

Check your BIOS settings my friend, my 5500xt gave the same issue. Check your BIOS settings…
PCIe Link Speed = Gen2

4G decoding = Enabled

CSM Support = Disabled

I would also try updating your BIOS as well. I hope this helps.

Thanks for your reply, but I have 7 Nitro+ still working in the rig with risers. I think it is because of something else about that GPU…

I am having a similar issue with my Gigabyte 1660 Super. It worked for a while, and now can only work in x16 slot when I moved it to a new motherboard.

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.