Increase your income with Hive. Invite your friends and earn real cryptocurrency!

RX 6600 XT - unable to prepare kernels: clCreatekernel (-46) + autoreboot


I have a problem with my RX 6600 XT.
When I want to mine with Phoenixminer 5.9, I have this error (same problem with older version of Phoenixminer) :

I have tried :

  • New install with the latest version of HiveOS (0.6-212@211125) => same
  • ethminer => failed to load binary kernel ( screen here )
  • Bminer => CudaError ( Screen here )

I have this problem with this card on two different RIG.
Actually, my GC is plugged directly on the motherboard of my test environment.

Anyone have already encountered this problem?
I can’t find anything on the forum about this :confused:

I facing the same issue with RX6700 xt. If you find any answer please let me know

Hab eben auch ewig versucht.

Lösung des Problems: Einfach Phoenix auf 5.8c stellen

Thanks for your help, but I have exactly the same problem on 5.8c version :confused:

Hello, I just had a problem on my rig by adding a 5th graphics card. I have a 6600 XT and three 6600 that were running fine until now.

I wanted to add a second 6600 XT and… big problem.

GPU driver error, no temp or DEAD.

The card is recognized and starts correctly, it even went up to 15 Mh during one of my manipulations but the miner crashed right after.

The miner stops every time and impossible to send a command to the rig.
I tried everything, the beta version or the old versions of HiveOs. The different OC, the installation of the drivers, or the different commands:

hive-replace -s -y
hive-replace -s
hive-replace -s -stable
hive-replace -s -beta

I checked the riser and the cables that I even changed just in case but nothing to do.

I removed one of the 6600 to see if I could run two 6600XT and two 6600 to see if the problem comes from the new XT and indeed it does. Even with 4 cards the rig still restarting, so I unplugged it and put my three 6600s and my first 6600 XT .

I don’t know why there is no problem with the first XT. It’s when I put the second one in that the problems start!

Guys, we really need help here!

So i was running into the same issue while using Phoenixminer. Tried multiple versions but didnt work. Ended up trying multiple miners and found lolminer version 1.37 seems to work. im only running 2 GPUs on this test rig. one is an old 390x and a powercolor RX 6600 non xt. the 6600 was showing the same exact issues you are describing until i made this change. hope this helps.

1 Like

Fixed it by using different kernels. By default it use optimized kernel, so for 6600XT used 0, and 1 for another gpu’s.
Sorry about answering after 25 days, but it may help someone.
For 1st gpu RX6000 and 5 another ones that run without errors.
-clKernel 0,1,1,1,1,1

-clKernel Type of OpenCL kernel: 0 - generic, 1 - optimized, 2 - alternative, 3 - turbo (1 is the default)


Work perfectly !!
Thanks for your help :slightly_smiling_face:

Hi there,

Can somone help me and inform me where can I add this clkernel command?


Add it to “Extra config arguments:”.

1 Like

Cool thanks man

Thanks bro, saved my days :slight_smile:

Hey guys, all new to me. Having the same problem from day 1, which was 2 weeks ago. This is the most promising post I’ve seen, but I have no idea where to make that change. Where do I find “Add it to “Extra config arguments:”.”

WooHoo!! Found where to add that line and my 6600XT is finally mining! Very much THANK YOU!

Thank you for this! It worked!! Now getting 33MH for 60W!

what OC settings are you using on the 6600xt

This is running stable.

Hey guys, new / old issues. Rig was running fine for about 5 months. I shut it down to play around with cooling fans on the frame. While it was down, I decided to rearrange the cards - Nvidia, AMD together as apposed to mixed. Wouldn’t start mining, but realized I hadn’t changed the kernel order. Corrected that, but still no joy. Here are the screen shots i managed to get. HELP!!!

GPU1 is a 1660 Super

So if anyone ever see’s this post, never mind. I put the card order back and everything works just fine. Only question now is, why didn’t the flight sheet / miner extra config changes I tried to make to reflect the new positions of the cards not take? It would always revert to the original and therefore couldn’t mine.

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.