More
referral
Increase your income with Hive. Invite your friends and earn real cryptocurrency!

RX 580 8GB MSI OC Won't Flash (Error 0FL01)

Hello,

I got a basically free RX 580 8GB MSI OC that seems to have a bios issue. I suspect the previous owner flashed the incorrect bios and got scared and sold it to me for pennies. Or its broken and im not out that much.

I am trying to flash it within HIVE OS (No access to windows at this time) and I have tried a few Bios that I thought were correct, but continuously get a Error of 0FL01.

I can’t find much info on my card, so I can’t guarantee I am using the correct bios. Any help would be appreciated to try and bring this card back to life! Here is a picture of the GPU:

I believe this is the MSI RX 580 8GT OC

here is the Error:

Blockquote
=== Flashing card 0 ===
AMDVBFLASH version 4.71, Copyright © 2020 Advanced Micro Devices, Inc.
Old SSID: 3417
New SSID: 3418
SSID mismatched
ERROR: 0FL01

UPDATE: I Successfully flashed Bios using SSID 3417 from TechPowerUp, however the card (Shows flashed correctly) is still not usable within the system, showing a red X box on the lefthand side of the Card View.

So you flashed it but its not working. Are you using OC settings ?

No, I am using original, nothing is filled in so I’m assuming default. Nothing else OC on that rig.

There still is that red X and box next to the graphics card under HiveOS, as if it’s dead / not working. I get 0 readings from fans or temp sensors.

But, the fans are spinning when it’s booted.

I should also mention it takes a couple times for the flash to be done successfully. I’m not sure if that means there’s a problem or if sometimes they fail.

I searched for a bios using the same SSID so I believe I have the right vbios

Did you use force flash option?

First time flashing on HIVE, how could I do that?

The V Bios version after flash is blue, which I believe indicates a successful flash