Increase your income with Hive. Invite your friends and earn real cryptocurrency!

RX 580 4 GB is dead? SMU load firmware failed


I got issue in one rig from yesterday. One of cards (RX 580 Nitro+ 4 GB) has been hung up. TRM has been restarted but only mine with 5 cards instead of 6.

I reboot rig and after that on dmesg I got errors:

amdgpu: [powerplay]
failed to send message 254 ret is 0
[powerplay] SMU load firmware failed
[powerplay] fw load failed
smu firmware loading failed
amdgpu: amdgpu_device_ip_init failed
amdgpu: Fatal error during GPU init

amdgpu: probe of 0000:06:00.0 failed with error -22

Card itself is detected by hiveos and using lspci command , but on hiveos not showing any temp , memory size or fan speeds so it can not be used to mine . I check card in other riser and issue is the same . Does card is dead? I did not do any updates / upgrades / bios flashing.

I will be grateful for any help.


At link provided it is simmilar issue but not regarding my case. I have firmware files and I do not get any error regarding missing files. Other 5 cards are also RX 580 Nitro+ and they are correctly detected. like I said everything was worked correctly and stoped , without any ingerention from my side. I also try to reinstall hiveos (latest version from April and old one from January) - errors are same.

hi gregor.
I am experiencing the same problem with my 8gb XFX RX 570.
did you find a solution?

Hi all!
Has anyone solved the problem described here?

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.