Increase your income with Hive. Invite your friends and earn real cryptocurrency!

RX 5700 XT Bricked - How to Restore and Bios Mod the right way

I tried flashing an updated bios to my Gigabyte RX 5700 XT OC 8GB and ended up being bricked. See below for further details.


  1. How do I restore the original bios? I’ve seen instructions from this video to run the AMDVBFLASH in DOS and try to restore that way. I haven’t given it a try yet, but I am thinking this is my first step to restore the bios. Please let me know if there’s a different way to restore bios or if there’s a plan b in case the AMDVBFlash doesn’t work.
  2. Is there anything special or different on how to flash an updated bios on the Gigabyte OC 8GB version than other versions of the 5700 xt? What’s the right way to flash the bios to get it to work for this card?

Steps I took to flash bios:

  1. Download original bios from VBios in Hive
  2. Download Red Bios Editor from Igor Labs
  3. Load the original bios and edit VRAM timing straps by copying 1550 to 1800 and higher. This card only has one memory type.
  4. Flash bios in Hive using updated rom file and with force flashing ignoring security checking enabled
  5. Restart the rig
  6. System would not reboot. System went to black screen.

System specs:
Motherboard: Asus Z390-P
RAM: 2x CORSAIR ValueSelect 4GB 288-Pin DDR4 SDRAM DDR4 2133 (PC4 17000) Desktop Memory Model CMV4GX4M1A2133C15
SSD: Team Group GX1 2.5" 120GB SATA III Internal Solid State Drive (SSD) T253X1120G0C101
CPU: i5 9400
OS: 0.6-190@210106
Drivers: A - OpenCL 20.40 N - 455.45.01
Kernel 5.4.80-hiveos
GPUs: 2x RTX 3070; 1x RX 5700 XT (system worked fine with the two 3070s running; added the RX 5700 then stopped working after bios mod)

Boot the system without the card, on the web panel, within worker options - enabled “Maintenance Mode (Without Drivers)”.

Reboot, plug the bricked card in, and upload stock bios to the card. Hopefully the system will boot with this enabled. If it doesn’t, you can try booting alongside another AMD card within Windows and flashing that way.

In short answer to your question, you should always use the exact model of the card that you own. I like to look for the same brand, model, make, and memory type. You can download the stock bios from Hive though, which then will be original card’s bios.

Highly recommend (in the future, if you didn’t do it for this one) to save your stock bios alongside the modded version, so that way in worst case scenario - it’s easy to reflash.


i have the same problem, when I want to flash in hiveos then came this: unexpected gpu brand undefined

can someone help me please?

thank u bro you help me really

Hiveos also has amdvbflash installed. Assuming you can boot your rig and ssh into it (or connect via the hive shell), you can type amdvbflash -i to list all available GPUs (must be run as root or with sudo). You can also check amd-info. Assuming the card appears in amdvbflash -i as gpu 0, you can flash it with your original bios by running:
sudo amdvbflash -f -p 0 /path/to/original/bios.rom

Sometimes you can even boot, then this is the only solution:

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.