Increase your income with Hive. Invite your friends and earn real cryptocurrency!

RX 5700 witht Hive OS Beta not mining

I installed Hive OS Beta, updated it to the latest version, and then installed the latest AMD 20.10 driver(for my asus rx 5700 (not xt)). During installation of the driver, at the end, there was only one error: “Error! Could not locate dkms.conf file.”. I tried to reinstall the driver, but the error persists. After that, I start Claymore miner and get the following output:

  • OpenCL initializing…
  • AMD Cards available: 1
  • GPU #0: gfx1010 (AMD Radeon RX 5700), 8176 MB available, 18 compute units (pci bus 3:0:0)*
  • POOL/SOLO version
  • AMD ADL library not found.
  • /hive/miners/claymore/ line 25: 23426 Segmentation fault (core dumped) ./$CLAYMORE_BINARY_NAME
  • claymore exited, waiting to cooldown a bit

So, I have two questions:

  1. How to install the latest AMD 20.10 driver without any errors?
  2. What else needs to be done, to start Claymore without errors?

Did you make it work? i have the same issue

I have the same issue too

Beta wersion on my 5700 isnt working what can Ido?

Am havin the same problem on beta hive, but with phoenixminer. Here’s my hard, with 4gb Ram of the system:

The card is a Sapphire Pulse with Micron memory.
This is the error I get:
2020.12.03:19:07:25.561: eths Eth: New job #ba31dae7 from; diff: 4000MH
2020.12.03:19:07:25.859: GPU1 Light cache generated in 2.6 s (24.1 MB/s)
2020.12.03:19:07:27.116: GPU1 GPU1: Free VRAM: 7.922 GB; used: 0.062 GB
2020.12.03:19:07:27.116: GPU1 GPU1: Allocating DAG (3.98) GB; good for epoch up to #381
2020.12.03:19:07:27.118: GPU1 GPU1: Allocating buffers failed with: clCreateBuffer (-4).
2020.12.03:19:07:27.118: wdog Fatal error detected. Restarting.
2020.12.03:19:07:27.905: main Eth speed: 0.000 MH/s, shares: 0/0/0, time: 0:00
2020.12.03:19:07:29.561: eths Eth: Received: {“id”:0,“jsonrpc”:“2.0”,“result”:[“0x790aaf5bc0c7e0160ac992d618677c4099fb41ec873b704b56feccfd90a3944b”,“0x24a739dd7e88652c7b9c8b21ab1ea88a6a1bc824232e6ffb030387c1518290d7”,“0x0000000112e0be826d694b2e62d01511f12a6061fbaec8bc02357593e70e52ba”,“0xadadfe”]}
Anyone what might be the problem.
Thanx in advance!

re-install hiveos beta and use the embedded 19.30 driver…that works fine.

if driver update is needed, check my guide thread here in this forum. there I tell what to do when you have dkms.conf error ! little search should have helped…last entry is just 4 days old…we dont need a new thread for already solved problems every time.

@ jumpnkick:

you cant run 8 gb cards with just 4 gb of system memory…dont know why this has to be explained

Sorry to tell. That might be the case for RX 5700 XT, but I have 600 RX 580 8gb, all of them on 4 gb systems, working for years now, and they work just fine.
In anycase, I will try upgrading RAM.

did the dag file you try to load into vram hit the size of 4 gb?

The problem was actually system’s RAM. You need 8gbs to run rx 5XXX series. But rx 5xx, even if they are 8gb GPU’s run just fine, on 4gb RAM systems.
So if anyone get’s stuck on this, the solution is quite easy: Beta version of hiveos, and 8gb RAM system.
I bios modded the bitches, and am getting over 59 mh/s, on 109 w.
Another problem on this GPUs is high mem temps, but after reading quite a bunch of info, the general conclusion is that if your mems are in the lower 90’s tops, you should be fine.
Thanks for the answers, hope my experience helps somebody else.

1 Like