Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Rx 570 8gb giving all invalid shares

Hi! I have been having problems with a rx570 for a while. I boot up and it starts mining but it gives all invalid shares. I’ve tried mining multiple coins with multiple different mining softwares, updating hive os and the AMD drivers, adjusting my overclocks, moving the card to different x16 ports, etc.It outputs video and runs the software it just only gives invalid shares. I did notice that the card was a little looser in the port than my other gpu, but I tried all 3 x16 PCIE slots in my motherboard and nothing worked. I even booted from a usb with a brand new hive os installation with new drivers and it still didn’t work. Anyone have a clue what might be going on? or is the gpu just broken? Thanks in advance!

Here is a picture of the new copy of hive os I booted to with the usb. It kept mining after the unrecoverable error and I got a couple of those while the card was still working so I don’t think that is the problem although it may be a symptom.

Try firing it back up and posting the miner logs from various miners/algos.

I tried a couple different algos and got different results

Alephium and srbminer-multi got hashrate but didnt find any shares

Ergo and lolminer got hashrate and all invalid shares

And I tried Ravencoin with nbminer and teamredminer, with nbminer It didnt get any hashrate and eventually got an error and shut down, with teamredminer it immediately got a “GPU initialization detected stuck” error and didn’t do anything

Try setting dpm state to 1, removing memory clock and rebooting.

If no change you can try flashing another rx570 bios that has Samsung memory

If all that doesnt work the card is probably damaged in some way, you could try running it under some graphical benchmarks

I think its damaged in some way. I tried your recommendations and nothing changed so I installed ubuntu on a usb and ran that. while it does boot and run there are major screen glitches and visual artifacts so I think its a hardware issue. Thank you for all of your help though! I really do appreciate it!