Increase your income with Hive. Invite your friends and earn real cryptocurrency!

RX 570 4GB different hashrate

Hi all. I bought a Bitmain GPU Miner G2 from my friend and working now with HiveOs lastest version. it have 7xRX570 4GB GPU. im mining for Ethereum with lolminer but my first gpu (GPU0) mining with 25MH but other 6 cards mining with 10~11 MH. i try change card slots between GPU0 with all others but after all nothing changed. can anyone help me?


up! up!

the motherboard is x16/x1* 100%

all cards connected directly to board. no have any risers. this is a complete rig. bitmain GPU miner G2

4GB cards will only hash at about 11-12 MH/s in standard Ethereum.
If your GPU0 is a 4GB card, then your hashrate on that card is false. Several miners have posted pics and videos of RX cards with crazy hashrates, but all the shares are rejected by the pool.

What are your miner settings?

See the whattomine page for the RX 570 4GB:

Ethash (Ethereum)
Win10 —> 8.00 Mh/s @ 120W
Linux —> 12.00 Mh/s @ 120W

Side note: I hope you didn’t get ripped off by your “friend”. RX 570 4GB cards are pretty much USELESS in Ethereum mining now. Your profit for the whole rig including electricity for the whole month will be less than $200 USD. You’d make more money removing all the RX 570s, selling them for $99 each and using the money to buy something else with more VRAM to put in the slots.

Oh! Thanks for your reply. But I’m afraid I understand what is the problem. So normally I not have any problem. :slight_smile: because my all cards normally mining totally 12~13mh X 7= 85~90 mh(this should be)
But now my main board simulating first card for full bandwidth 24-25 MH by hijacking from others cards 2-2,5 MH. First card 24 MH on screen but my total MH same :grin: Finally, if my all cards give 12-13 MH same time, I will already give 13x7=90 MH but now 24+65=89 or 90.

You’re probably correct.

Which miner are you using? If you’re using LOLminer, it now has a kind of “enhanced zombie mode” which requires full PCIe slot bandwidth in order to get a 4GB card to mine at almost full hashrate.

If the first slot in your motherboard is x4/x8/16 and the others are x1, this would explain the weird hashrates. Only faster that x1 slot(s) will give you the higher hashrate.

New Zombie Mode Performance:
– DAG Epoch 393: 27 MH/s
– DAG Epoch 400: 21-22 MH/s
– DAG Epoch 405: 14 MH/s

I don’t know how the Bitmain G2 motherboard is wired to the slots, but it might use x16 for the first slot.

1 Like

Yes, you are right. GPU miner G2 have 8 slots pcie.

All slots are x16 form but only GPU0 full x16 speed, all other slots have x1 speed.

At bios have some settings for slot speeds but when chancing these settings GPU0 performance is reducing.

We have resolve all problems. Thank you. :slight_smile:

Glad to help a little!

1 Like

This article helped me understand also. Thank you for sharing. Both of you

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.