Increase your income with Hive. Invite your friends and earn real cryptocurrency!

RX 480/580 was working, Now presumably dead

Hey all, I’m not the type to start a new post/post at all on any forum, I always search and search and search, I’m at the mercy of someone who has had this problem that I cant find now…

So I got a “RX 580” it ran in hive for a little over 24 hours no problems (showed up as an RX480 but they’re basically the same so I digress) I have a photo of the EXACT settings/what the bios said before it fckd itself, nothings changed and when I decided to reboot my rig today, its showing up as “Radeon RX 470/480 · AMD/ATI | Unknown Memory 0-0 · xxx-xxx-xxxx”

I’ve reinstalled hive, located what I think is the “stock” bios and flashed it (I saved what was “working” same results either bios) tried multiple risers/cables, the card on it own etc.

I’m completely stumped, Any and all useful help is appreciated, Thankyou in advance, Jrs.


EDIT Here is an upload to the “Original” vbios from the 480/580 i have -


Do you test without Flashing your Rom. Only Original Rom?
Do you have test card without other card?

Can you share your original Bios? i cannot found :confused:

I’ve tested on “original” vbios, ive tested the card in multiple motherboards/risers/slots, i will upload the vbios that was on the card to begin with, thank you for your time @Kenshinji

@Kenshinji heres the vbios that was on the card when i recieved it |

i see your problem

Can you contact me to Telegram @kenshinji59

yeah nah mate, we have contact on this site, whats the problem> share it to anybody else that will have this problem in the future.

Your Bios is for RX 580 and Already Modded . Its not Original Bios

its not for RX 480

image 580

image 480

I can be try to fix. I need picture of your Card or box


Maybe you can test :

If work, you can modded thats bios.

Thankyou so much for helping me, ill test the v-bios when I wake up (its 5am and i need sleep) i will take a photo of the stickers on the back of the card when I wake up also to try get to the bottom of what this card really is and make it work, again thankyou so much for what you have done so far @Kenshinji

By the way @Kenshinji I bought the card used recently, I have not modded the vbios, it WAS working but stopped now.

if vbios of techPowerUP work, i can be help you for mod

i tried the “stock” bios, didnt work, im going to sleep, i will try all configurations with windows tomorrow, thankyou sir, talk in around 6 hours :slight_smile:

how did you flash the bios ? if you used HiveOs did you select force flash ignore errors?
Sometimes it doesnt flash it correct and you need to force it.

Yeah I used force flash each time, im about to put it into a windows machine and see what it says

ok so in windows it shows up in device manager code 43, ive tried multiple bios’ patched and unpatched, im beginning to think this cards dead

I just dont understand how it was running fine and a rig reboot made this happen…

you really need to find the correct original bios and flash it and then see what happens. otherwise it might be dead.

yeah im on techpowerup forums now figuring out what the OG bios is, then I will be back here

ive got the OG bios, still no luck, is there anyone on here that could point me in the right direction to figure out whats dead and i can repair it (ive never repaired a GPU, but i have years of experice with xbox 360/PS2 modding/repairs) I have a voltmeter and a temp adjustable soldering iron.