More
referral
Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Running out of RAM every 7 days

Somehow, during a seven-day period Hive OS starts to use more and more system memory until it eats up all my 8 GBs and has to reboot. Then the process starts again… Is this some sort of memory leaking or something similar? What should I do?

1 Like

Hey mate I am having the same issue but mine is daily. Every night I have to reboot my miner because the system memory goes from 6.4gb (8gb stick) down to roughly 850mb within a 12 hour period. I’ve tried googling answers plus I have also been in contact with the hiveos tech support and I’ve stopped hearing from them so im not sure what to do. I’m thinking of whiping my ssd and installing a fresh copy of hiveos and see if that works🤷‍♂️

2 Likes

Thank god at least someone has this issue too. I was starting to get desperate as this seemed to only happen to me. I couldn’t find anything on Google either. Really strange. I haven’t considered reinstalling the OS as having to reboot every seven days isn’t that big of a deal for me but if it works out for you please tell me, and I’ll do it too!

Edit: maybe it’s a problem with the RAM stick… do you happen to know what model and brand yours is?

1 Like

i am having the same issue, i normally have 2.3GB of ram after the miner is started. Then over 3-4 days, it leaks to about 1.9-1.8GB of ram, and then INVALID SHARES start to happen (OC is very light, thermal paste is fairly new)

I’ve been searching for a fix for a while now, rig is always updated and monitored so… i really don’t know what could be doing this…

1 Like

I switched to lolminer to dual mined eth/zil, and now it doesn’t take 7 days to run out of memory but just 17 hours… Before that, I was on phoenixminer. What miner are you using?

Same here, 8Gb out of memory every 4 days. I’m using Gminer now. Switched from Phoenix and Teamred. Any solution?

1 Like

I take it there is no solutions here yet? 16GB of RAM takes about 7-8 days to start running low. There is a memory leak somewhere in HiveOS is my guess. In Windows this is a major issue with some NVIDIA drivers, I imagine we are seeing something similar in Hive.

Haven’t found any solutions…

using mmpOS and having the same problem with gminer and AMD cards rig, no solutions yet apart switching to lolminer

Now that kind of makes since why I didn’t really notice until I switch all my cards to GMiner. So do I need to switch my AMD cards back to TeamRedMiner, I just hate leaving money on the table being charged 2 Dev fees and not getting the higher difficulty shares for my mixed Rig.

Haven’t found any solutions yet. I’ll try to change the miner again someday. But for now the rig reboots automatically when runs out memory thanks to watchdog. So this problem doesn’t bother me much.

Just wanted to update everyone, I put all my cards (AMD/Nvidia) on LolMiner and it doesn’t seem to be eating Ram any longer. Lost about 4mhs total between all cards switching from Gminer but it seems stable with a little lower power draw and payout is really close to the same daily rate. I’m about 18hrs in now. Will try to send an update in a few days.

I can confirm that in my specific case RAM memory was killed by gminer miner on start it had 400mb (2 gpus) and after 20 hours took 1100mb+. So I have changed it with another miner.

I also can confirm that t-rex miner does not have such a problem based on my observation.

So there’s most likely an issue with miners soft rather than with HiveOS itself.

The command I used to check current RAM possession by processes
ps aux | awk '{print $6/1024 " MB\t\t" $11}' | sort -n

Hello, I am having the same issue as you all… Love Gminer it is the best miner by far for may reasons but it seems to have an issues with some AMD cards in hiveos… But not all AMD cards it seems… I have 4 AMD rigs all running 6600xt and 6900 xt’s on TB360 V2’s boards, 240GB SSD, 16Gb DDR4 2666 RAM, Celeron 3.2GHZ and this problem only accurse on 2 of them. ATM I just do a reboot every 48hours on the 2 rigs which is a but shit. Has anyone tried to contacted Gminer directly?

I solved this problem with this workaround:

A) Create file:

touch clearcache.sh

B) Make it executable:

chmod 755 clearcache.sh

C) Modify it:

nano clearcache.sh

D) Text to be copied and saved in file:

#!/bin/bash

sudo sh -c ‘echo 1 > /proc/sys/vm/drop_caches’

sudo sh -c ‘echo 2 > /proc/sys/vm/drop_caches’

E) Command to schedule it:

crontab -e

F) Line to append in it, to execute the script every day at 3am:

0 3 * * * /home/miner/clearcache.sh

Take note that I use mmpOS, so most probably the path to the script created will be different in HiveOS

Why dnt you just reboot once a day…? Doesnt affect anything negative butt all works fine.

  1. the same can be done by hugepages -mc1 (clears PageCache) or hugepages -mc2 (clears also denries and inodes) built-in Hive OS command
    Please not that PageCache isn’t bug.

  2. GMiner v2.70 and earlier has memory leak bug which fixed on v2.71

HaloGenius

Do those hugepage commands are same on all miners. I temds to go for nbminer for myself.