Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Rig keeps going offline Hiveos

I currently have an issue whereby my rig has all of a sudden started going offline. It had been stable for months on hive os version 0.6-222@230711. I decided to stop mining ETC and try Kaspa but that was a failed attempt as my rig could hardly mine anything of Kaspa so switched back to ETC with all the same settings and OC’s as before but now it keeps going offline, I’ve tried resetting OC’s to default and bring them back up to just shy of what they were before and I held stable for 10 hours then decided to go offline again. I run 3x 1660, 2x 1660 ti, 2x 1660 super, 1x 3060 lhr and 1x 3070 lhr. Any help would b3 massively appreciated.

Is the rig going offline on the dashboard and poolside? Or only on the hive dashboard side?

Mainly on Hive dashboard side. It seems to still be mining on the pool but has dropped out twice on the pool, I’ve tried disconnecting various cards and running it with various OCs and still the same. Lastest attempt last 3 hours, sometimes it’s minutes. I’m stumped as o what it could be. It’s only been a problem since I switched to mine another algo then switched back to the original.

If its only on the dashboard side you can try changing api servers, run net-test from the rig (either locally with keyboard and monitor, or same network via shellinabox) preferably while its showing offline and pick one of the api servers that show low ping and change your workers mirror to that in settings → mirror select.

If its disconnecting at the pool too it could be a network issue, plug a monitor in and see if the rig is frozen or just doesnt have network connection (you can use net-test to check this)

What cards/ocs are you running? A screenshot of your worker overview screen will work

Hi, its only disconnected from the pool twice, im going to try a reboot when i get home from work and default all the OCs and see how long it runs for, i have a small screen attached to the rig to keep and eye on it and when it goes offline its not showing the usual stuff that you see when mining normally and its blank and flickers probably once a second. I dont think its a network issue because my small ASIC hasnt missed a beat yet so it has to be the rig. These are the best i can do as its from my phone, these were from before i tried to mine Kaspa and took them for reference.

Id guess its oc related crashing, if you havent already, flash the latest stable image, anything thats showing lhr is going to be almost 2 years out of date by now.

Would also change all your core clock offsets to locked core clocks(as low as gets full hashrate), and remove power limits. Hive treats values above 500 as locked core values

Hi, just want to thank you for your help in advance also as ive had a couple of weeks of headaches with this and appreciate you trying to help. Ok its worth a try, you will have to forgive me but im still not completely competent with all the technical side but that would require me to do it on my ssd by removing it and flashing it like i did when i first set up my rig wouldnt it? Unless there is another way i dont know about. I will have to play around with OCs once ive done that. Ive only ever done it as the screenshot shows and had no issues for 2 years apart from the odd internet outage but thats it and it just seems odd that i changed to a different algo and then changed back and now all these issues. The power limits were only there as a safeguard from the cards overheating etc as i did have a few issues with temps and that kept them in check but will take them off and see what happens.

You can update from the rig by running hive-replace -s -y or by removing and flashing the same way you installed originally

Ok thats perfect, i did read about doing it through the rig but wasnt sure what to do, ill try that first and if that fails i will re flash the ssd the same as i did when i built my rig. Thanks so much for your help. Ill let you know how i get on.

Hi again, I’ve re flashed the ssd with the most recent stable image and still no good. I have managed to get this from the small screen attached to it but have no clue what it means.

I would try another drive

I have disconnected 3 cards from the rig that were in a pcie 1 to 4 splitter and its held stable now for around 3 hours. I have a new one coming tomorrow to try and see what happens. I’ve locked all the core clocks as well. I have also noticed these to errors during boot up but it’s still booted, is online at pool and mining. Think I will try re formatting the SSD then re flashing again tomorrow and see if that helps as I’ve seen some info that it may be trying to load some old setting that may still be on the drive. Don’t think there is but will try it anyway. Here are my errors just in case you have seen it before and know what’s going on.