Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Radeon Xfx 470 8GB system can't detect GPU


I tryed today to use Radeon XFX RX 8GB but system wasn’t start. Beside information about loading AMD drivers nothing happens beside restarts after 60 sec. I tried to fix GPU by Riser also direct on MB and results was the same ;/ GPU is not detected.

On GTX 1060 it works normally, detect GPU without any problem. Any suggestion how I can proceed?

I have the same problem. I have two of the same xfx 470 cards, with both I changed the strap, they worked for an hour after that, after that one stopped and the system constantly rebooted and it ejected the same screen as with you in the picture. i removed that problematic map and the others work neatly. I tried to insert it into a PC running Windows 10 and the system does not see or recognize it. He only sees the afterburner program, but all the ocpies are “off.” does anyone have a blanket on how to handle this, or has that card died out and he can’t come back to life anymore?

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.