Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Radeon VII mined perfectly for 1-2 years. Now it spits out errors and can't mine


I’ve been mining with my Radeon VII since the beginning of 2019. It has been smooth sailing thus far. Until today, there is some cryptic messaage that I can’t particularly undstand, and will not mine anymore.

I know it probably isn’t the card, because in windows I can mine perfectly fine using NiceHash. Albeit at a much lower hashrate due to the lack of C mode in TRM.

Haven’t touched this mining PC for eternity. My other mining rigs have been going for years without issue.

I’ve re-flashed the SSD from v.203 to v.217 to v219. All the same result.

Would someone be kind enough to help me out here. Would greatly appreciated. Not looking back to windows, heh.

First of all, does it work? Can you drive a display from the card?

Yes, I took all 6 VII’s out and installed them each into my personal gaming computer. Each of them worked flawlessly, albeit I only tested GTA4 which is more than a decade old.

Regardless, no artifacts or crashes for each 30 min playtime for each card.

Again, in windows it works perfectly fine, just a drastically lower hashrate vs. Hive.

Using 2x HP 1200w power supplies for 6x RVII and the X11AMP Boards. I have spare breakout boards and PSU to see if that fixes the problem.

So weird. Usually in my experience, it works, or poof the house smells like burnt electronics.

Not sure which miner you are currently using, but, lots of things have changed since you started.

My VII rigs are running on the following Kernel(#110) and August 2022 release, with Team Red Miner 10.2 with R Mode enabled:

And just to confirm, you tested the card since it’s stopped working in hive? It mines on windows fine currently?

And you are able to run the display on your hiveos rig off said card currently?

My rig is peculiar. I have 5x6800XT and 3x6700XT. Rebtech MOBO, 2x1200HP 240W power supply.

The highest version of the linux kernel that is stable is 0.6-203. Anything newer and it gets stuck at the console screen, never making it into the HIVEOS splash screen. It constantly throws out PCI I/O errors and begins a reboot look. 203 is the most stable for my RDNA2 rig. Previously it mined for 16 days straight with no issues,

However, this morning, i came to see all these error messages that prevent HiveOS from loading. I swapped to al new risers with the same issue.

I removed each GPU and put it in my gaming PC and was able to GTA5 for an hour each. No errors in windows.

Any ideas? I prefer not to install windows if possible.

Try hive on the pc you were running gta5 on with the same install that wouldn’t work on the rebtech.

Have you wiped the ocs/voltages when trying to boot?

I know newer nvidia drivers don’t work on the rebtech boards, so maybe they’re weird with newer amd stuff as well.

Good idea, however I don’t have the ability to run GTA5 on linux, so I wasn’t able to test it. Although, at stock settings for the 5700s, I was able to play dirt rally 1 for an hour each utilizing all 6 of the cards.

On my rebtech board with 8x RDNA2 GPU’s, I didn’t bother changing any of the overclocks or undervolt when testing to see if those parameters were what’s causing the problem. Still I/O errors and never reached the splash screen and i would have to manually power it down.

You’re correct in that the rebtech board does not support video out while NVIDIA cards are installed, I’d have to remote in using SSH to get a readout.

In my case, I have 2 AMD rigs, 6x 5700 RDNA1, and 8x RDNA2. For some reason, the 5700 rig is never stable on any version past 203. Not a big deal, but I can’t undervolt at all, so my 6800XT are running at 175w and my 6700XT are running at 130W. I’m beginning to think the Rebtech board is not ideal.

On the other hand, my NVIDIA rig with 2x2060S, 2x2070S, and 2x3070FHR has an uptime of 63 days and counting…

Anyways, I’m in the process of playing various games on my 6x RVII on my other gaming computers and it works flawlessly. I lapped the mating surface to the die and the temps are drastically better.

At this point, I’m guessing that the Rebtech board needs a BIOS upgrade or something.

In addition, my 5700 rig won’t undervolt at all, been trying since 2019 to no avail. Maybe it is the old Mobo I used back in 2017 during the first mining rush.

Ah well, if anyone has anymore insight into this inane issue, please let me know, I’d greatly appreciate it so much.

So hiveos works fine with the viis in the system you were playing gta in windows on? They only don’t work on the rebtech?

It is not your AMD GPU mix. I have such mixed and matched across my rigs.

There are some version limits with some of those Rebtech boards. Plenty of internet posts sharing limitations at driver levels, etc.

For your 6700/6800 series, you’ll want to be to at least HiveOS kernel #83. But you’ll really want to get to #110 and TRM 10.2 for R-mode tweaks to the VIIs. All of my AMD rigs are on #110 and latest without issues.

Swap out the Rebtech and update your overclocking to modern times and I suspect your issue goes away immediately.

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.