Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Radeon VII - ETH Hash Rate of 100+MH/s - How to Guide Using TeamRedMiner

Hello, I manged to figure out how to get mode C of TeamRedMiner to work which fully utilizes the 16GB of VRAM on the Radeon VIIs on Hive OS. Doing this unlocks the potential of getting hash rates of 100+MH/s while ETH mining with Radeon VIIs. Please note that by doing this sometimes hash rates on non-VII cards are slightly reduced. I found all of this info in the ethash tuning guide for team red miner (starting at line 462): teamredminer/ETHASH_TUNING_GUIDE.txt at master · todxx/teamredminer · GitHub

Step 1: Access shellinabox so you can get to the terminal of your mining rig.

Step 2: Once you’re at the terminal, install Vim so you can edit the grub file:

  • apt install vim

Step 3: Start editing the grub file (If you don’t know how to use vim this quick tutorial video will help Vim Basics in 8 Minutes - YouTube ):

  • vim /etc/default/grub

Step 4: Go to the line where you see GRUB_CMDLINE_LINUX_DEFAULT and insert these parameters inside the quotes and then save/quit the file:

  • amdgpu.vm_block_size=10 amdgpu.vm_size=1024

Step 5: Update grub:

  • update-grub2

Step 6: Reboot your mining rig for the changes to take effect and go back into shellinabox.

Step 7: Double check if you did the previous steps properly by using the following command. If you did everything properly, you should see ‘block size is 10-bit’

  • dmesg | grep “drm.*block size”

Step 7: Tune the overclock settings of your GPUs to get that hash rate up. The parameters that worked for me are:

  • Core Clock: 1750MHz
  • Core Voltage: 980mV
  • Memory Clock: 1150MHz
1 Like

Hi thanks for this. Can you please advise Hiveos version and driver version you have used for this?

Hive OS Version: 0.6-198@210210
Kernel Version: 5.4.80-hiveos
AMD Driver: OpenCL 20.40

Found this guide that explains it better and includes how to include memory timings:

1 Like

Hello the guide worked for me fine too, I am using already some time, with thise settings

  • Core Clock: 1600MHz
  • Core Voltage: 900mV
  • Memory Clock: 1100MHz

I do 100mh/s with 65° mem temp

one question how is possible to apply the timings setting that you find in the guide with hiveos?


sorry just saw now the guide, i will try…

Hello, I have 2 watercooled Radeon VII, and I followed the steps until the update update-grub2, where i get and error ( Syntax error: EOF in backquote substitution)

What am I doing wrong ?

You need to delete the already existing " in the line. The " marks the end of the line so you’ll add it after you add the new config settins.

1 Like

Here we go !
It was a very easy mistake.
Due they are watercooled, they´re mining at 104Mhs and 110 Mhs

Im doing the agressive OC (Core 1800/993mV/1150 Mem). Hope it doesnt brick the gpu

Temperatures are fine. 32 GPU and 42 Mem
Thank you for the help


i have a VII with Samsung memory, can i push it a little more than in the tuning guide?
would it better be more on Core or Memory, Timing are for Samsung from the guide.

and for a hynix card, stay with 1700 core 1100 mem and agressive timings , is it better to push core or mem?

has anyone a fixed C mode ? or on autotune?


Many Thanks!
Air cooled works as charm

Hi dude, can you maybe send me your bios file from your vii.
i want to compare my to your file, because my vii is showing but not mining, not error 43 in win nothng.

Hey hey,

I’m using the stock bios. Nothing is changed there. Are you having the same GPU XFX?

Maybe even better you can find it here:

Btw have you checked your pciex riser ?

now i put it on pcie 16x, i was comparing in HdX the bios files, the look pretty same.
Did you got the exact issue like me? Discord Miners told me the card is death, but i got output and no error 43 … can i have your original stock bios before u flashed and the flashed one to compare the structure inside the bios


Just did an even more agressive OC.

115Mhs + on each Radeon VII

Thanks for your help guys ^^

Hi i have a problem and can’t solve it.

My 2nd radeon vii goes down until 77 mh/s (upload://zSGhxczz9iBJw0iEpJzqlWI4YQE.png)
with the config
/hive/sbin/amdmemtweak --i 8 --ref 7500 --rtp 6 --rrds 3 --faw 12 --ras 19 --rc 30 --rcdrd 11 --rp 11
sleep 60
tail -f /run/hive/miner.1
It goes to 85 and no more

Would you share your settings?
and timings?


Of course

Core 1864
mem 1155

/hive/sbin/amdmemtweak --i 0,1 --rtp 6 --ref 7500 --rcdrd 13 --rp 13 --rrds 3 --faw 12 --ras 25 --rc 38

** Note that this could potentially damage your Radeon VII, mine are watercooled.

Good Luck

Hey I have Radeon VII water cooled as well and Im curious how your cards have been doing with the aggressive OC since you have been running it?

So I am having the same problem. i get EOF error. I deleted the quotation and moved it to the end of the line. The only thing that i can see that is different from the guide and videos out there on how to do it is after the mititgations=off i have e1000e.EEE=0 at the end of the line, i added amdgpu.vm_block_size=10 amdgpu.vm_size=1024” after it then saved it. When i try to update-grub2 it gives me the EOF error …

AMD 20.40

Any suggestions?

Yes. do not copy the " from the text. do you own " behind 1024

1 Like