Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Radeon RX 5700 XT Bios mod


I’ve ordered some cards to assemble another rig,
As per usual I’m going to swap strings in bios.
On rx470 I was using HiveOS to read/write bios, is it safe to do it on beta image?

Cards are Sapphire RX 5700 XT Pulse

Kind regards,


Nitro pulse modded micron memory
Have a nice day


hi Tommy, is this mod also good for the 5700xt rog strix Asus and the 5700xt Nitro +? can I try or burn some cards? :grin:

Hmm am I brave enough to try this on my Gigabyte 5700 XT.

Edit: I tried it, increased my hash-rate from 53.2 to 56.7. Had to up the core clock back to 1400 though, increase of 10 watts from the wall. Seems stable after an hour.

I’ve always used GPU-Z in Windows for bios reading/writing.

I also may try the posted BIOS on my RX 5700s

Can we use the Hiveos included bios flasher for the RX5700xt or only on windows with flash tool from Igors Lab ?

By the way, you are modding the bios memory straps to 1500mhz or ar changing power tools options?
If yes which ones if you want to share ?


following the thread cause i will buy 12 pcs Sapphire Pulse RX 5700XT soon.


Answering my question, yes u can use HiveOs to flash, you can also mix the bioses between cards providing that the memory type is the same (samsung/micron).
If in doubt I’d highly recommend Jarek from forum, he is very busy so be patient and keep trying.

You da real mvp, we’ll try this on my remote rigs.

Tried 1.rom with Asus rx5700xt gaming (Micron mem)… bricked the card
-works on msi rx5700xt mech.

Just tried to bios mod through HiveOS and it bricked my whole rig. The OS isn’t booting up anymore. I’m using a remote rig and don’t have windows on the system. I used another PC to create the .rom file for one card, saved the original bios and flashed the one card with the modded bios from RBE. I did not “force flash” it as I was trying not to have issues. I have 5 Gigabyte RX5700XT Gaming OC cards. Can anyone help me get back up and running? I don’t even have display now on a monitor from the rig when I plug one in. Should I reflash the SSD with HiveOS Beta?

As an update, I was able to get HiveOS running with the cards I did not bios mod, but I cannot get the motherboard to recognize the bios modded card. I am not a windows guy, but is the only way to fix this to get the GPU hooked up to a windows system and flash it with the stock bios?

Also, my cards are running Micron mem.

Try this with default bios:

Update! I was able to follow some instructions on the red panda mining discord by a super knowledgeable guy. Changed some bios setting on the mb, installed windows and reflashed both cards with the stock bios and they are good to go! If anyone has issues with this card, please reach out. I took screen shots of the instructions to help your MB recognize and boot with the bricked cards.

1 Like

@Weaselmining - what did you have to adjust on mobo to recognize your bricked card?

I’ve got a couple i was going to RMA, haven’t been able to get them off of code 43 in windows

You need to enable CSM in the BIOS. And switch to legacy and UEFI. This should reveal the cards on boot.

1 Like

Ahh i will try this… hiveos won’t boot with them installed.

damn man, somehow i was moving a GPU off of rig to my test bench and it won’t get recognized by either computer now… i didn’t even flash it :cold_sweat:

rtx 3080 better)