Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Radeon 6800 not working with Asus B250 Mining MB?

I have an Asus B250 mining expert board, with 6 Nvidia 3070’s and it work perfectly.
When I attach one Radeon 6800, it will not get past the press delete to continue and it won’t even let me do that.

Any thoughts? Strange that a Nvidia would work, but the Bios won’t even get pas F2 when a Radeon is hooked in.

Manual was followed on where Nvidia and Where AMD can be plugged in. All risers and power confirmed. Just plugging in one Radeon 6800 to test.

Any ideas appreciated…


Did you tried to plug the 6800 in PCI16x port, alone ?
Did you tried this 6800 on another computer to confirm that it’s not DOA ?

I have not yet. I will do that and report back. Thanks!

From the internet thing, you’re not the one with problem with 6800 and mining motherboard, even other brand.

I got the same problem with same motherboard and 6800 XT Nitro+ SE
Stuck on ASUS start screen when I try to boot with a windows HDD
Boot perfectly with HiveOS HDD but Gpu is not reconized!
Got this error and the rig start mining without the 6800xt
I’ll try on my B360 F PRO when I’ll receive a new cpu for it

I update the motherboard bios and set pcie version to auto instead of 1.0
I see there are only the following version of pcie


I had to enable Compatibility support in the bios and I can see all cards now in the B250 Miner. Including the Radeon 6800’s no problem.


Okay can you send me a screenshot of the bios screen I can’t find this option

It’s under the “boot” tab and called CSM
You will see it.

You may also want to update your bios.

Especially if you don’t see that.

1 Like

I found it
You makes same settings as the photo or you have modified something ?

1 Like

Okay I think it’s good but now memory of the 6800XT seems to be not detected and of course it’s not mining

Same issue not support by HIVE OS

1 Like

Sorry for very delayed response.

This is because the current stable version of HiveOS does not support the card. There is currently an alpha version that does, and a Beta version should be released soon. I don’t have an official ETA yet.

I have same problem with my Asus B250 mining expert. I’ll try to set Boot from PCIE to legacy only and I try again.
I hope it works. Thanks.

I cannot tell you how much I appreciate you for this… I spent a good 8+ hours last night trying to get my 6700xt to detect. You’re a legend… <3

gigabyte 6900 xt

problem on hive stable, alpha, beta
please help

CSM mode Enabled
card in pcie x16
B450 Gaming K4 ASRock (P4.50 11/04/2020)
cpu AMD Athlon 200GE with Radeon Vega Graphics
ssd 120 gb
A OpenCL 20.40


So now you can use 6700xt on hiveos ?

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.