Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Problem: "WARN: ApiServer: failed to bind socket (Address already in use)"

As the title says i have that problem with TREX and i cant solved

1- I try to update the Trex version and Hive Version - Dont Work
2- I create a new flight sheet - Dont Work
3- I edite the flight sheet and add --api-bind-telnet 0 --api-bind-http 0 - Dont Work

Can help me??

Hi, I have the same issue since today after I updated to new hive os version.
Gried downgrading but it didn’t help. Tried lastt-rex version which also didn’t help.

Finaly I used gminer which mines since then.

Propably this could be yor solution in the meantime.


Hello, I also have the same problem after i updated my hiive os today.

edite the flight sheet and add this

“api-bind-telnet” : “0”
“api-bind-http” : “0”

For me its work well

Oficial doc

1 Like

Yes, i already try to add that, but dosent work
The “warning” persist

Adding this worked for me:

“api-bind-telnet”: “”
“api-bind-http”: “”

I’m having the same warning in my trex since I updated HiveOS from 0.6-203@210414 to 0.6-203@210415.

Configuring like @bdsmithtsu suggested stopped the warnings. thanks :slight_smile:

Interesting that after the configuration adjust, both ports are used by trex. I don’t know why trex keeps binding 4058 :expressionless:

This can be checked using the command: netstat -tunlp | grep rex

Thanks, this worked for me!!! :100:

The way @bdsmithtsu provided worked for me. Thanks.
It’s weird. Only one of the machines prompted this warning after upgraded to 0.6-203@210419

I’m still having the problem with them settings

Is there any other setting I can try

But still can mine just getting the warning

“api-bind-telnet”: “”,
“api-bind-http”: "

Hello everyone!

After installation on a new rig [email protected] everything was installed correctly and everything was updated.
But when you turn on mining, it gives out:
WARN: ApiServer: failed to bind socket (Address already in use), next attempt in 5 seconds.

How to fix?

In T-rex the options is diffrent. You need to add:

“api-bind-telnet”: “0”

( alternativly also, but I did not need: “api-bind-http”: “0” )

Hi I have this same problem! Where I put these codes? Is in the configuration of t-rex miner? Thanks

Update HiveOS: problem is fixed 0.6-203@210424 "OS VERSION"

Just update and select last version T-REX

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.