Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Problem booting to hiveos with 1 to 4 pcie splitter

Hello guys, I need your help. One of my rig just throw issues when booting to hiveos.
It cannot boot when I install 1 to 4 pcie splitter. works fine when i remove the splitter. It works fine before and I didn’t change anything. One day my rig shutdown and not able to boot anymore.


  • MSI B560M A pro
  • Intel G6400 + 8GB Ram
  • This motherboard has 2 1x slot and 1 16x slot.
  • GPU: 3x RTX 3060 Ti on splitter + 2x RTX 3080
  • on latest hiveos stable: Hiveos-0.6-217-stable
  • Kernel: Linux kernel: v5.10.110

What I have try:

  • Setting bios - Enable/Disable Above 4G, Enable/Disable Resize-able bar support
  • Setting boot to UEFI
  • Cycling splitter to across pci slot location (putting splitter on x16 also give me freeze/hang on boot)
  • Reflash SSD with hiveos latest image couple of times
  • I have one other rig, using same configuration bios and hiveos and works fine. Only this rig give me trouble.


  1. plug only 3 GPU without splitter, boot normal, mining normal
  2. plug only 1 GPU on splitter, boot normal, mining normal
  3. plug 3 GPU, 1 on x16 and 2 GPU on splitter, hang on hiveos boot. (screenshot below)

Does anyone have a clue what is going on with my rig?

what pcie gen do you have set? using the hive recommended settings?

Unfortunately this motherboard: MSI B560M A Pro doesn’t give me option to choose which pcie gen except for M2 Slot. But I am using all recommended setting from hiveos.

In fact I have setup another rig using same motherboard and splitter with more than 5GPU and works fine.

I have check the ssd and it’s healthy. I even switch ssd from the other rig and getting same error if I plug the ssd to this rig. I am so confuse right now.

Now I am thinking that the mobo bios might be corrupted, I will try to reflash tomorrow and see.

Splitters can be hit or miss some cards will work without issue while others will only work if you populate 1-2 ports. If you have a duplicate system, swap parts back and forth until you find what’s holding it back.

Hi sorry I just reply now, I found the issue.
TL DR: GPU Broken, system/hiveos will freeze if I plugged in that card.

Long story:
I start to give up the issue being on mobo bios, splitter or ssd / hive os installation since I swap the parts with my other rig and it still giving me issue on this rig.

I try to check the GPU one by one and find out that if this one 3060 TI plugged in, the system will freeze. It was not the splitter that cause the freezing all this time. Then I check with my gaming pc and that gpu cause my pc freeze as well. I sent the gpu to service center and they told me that the chip is broken and will replace it for me.

This is 2nd 3060 TI dead in one week(about 5 months usage) for me with 2 different behaviour:

  1. First one can safely boot to hiveos but not able to start mining or set OC.
  2. This one cause the whole system to freeze on boot.

It’s weird that I never had the card’s temperature above 65c, mostly hovering between 58c - 62c and yet the card still fails on me. I guess I need to lower the oc for my other cards and start adding lot of fans because it’s summer as well.

Thanks @keaton_hiveon for helping me debug this. Hope you have a nice day.
The issue is now solved and can be closed

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.