Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Other RX 6600 XT not recognised

Hi all,

I am trying to use HiveOS with 3x RX 6600 XT but I’m struggling to get 2 of the cards to mine. Hive indicated the cards need attention, but picks up there is 3 cards.

Intel(R) Celeron(R) G5905
Asrock z590 pro4
4gig ram
120 Sata SSD
3x XFX Swift 210 Radeon RX 6600 XT
Corair RM 850x psu



Hive details:
Hive 0.6-212@211130
Drivers 20.40(5.11.1001)
Kernel 5.10.0-hiveos #83

BIOS settings:
Enabled 4k encoding
Changed all pcie to gen 1 (5 of them)
Changed display to Onboard

Miner: TeamRedMiner
Pool: NiceHash EU west

What I’ve Tried:
Executing “hive-replace -s -y” in hive shell
Setting pcie gen speed to auto
Swapped GPU + riser pcie slots (all cards and their risers work) only seems to pick up the GPU of the gen4 pcie slot

Thank you in advance

Disable the onboard and direct attach your monitor to the GPU in the first 16x PCIe slot.

Disable HD Audio, NVME ports, WiFi, etc, in BIOS.

Did you test each card individually? If everything works try setting pcie gen 1 instead of auto, and like said above disable extra things you don’t need

Thanks for the responses.

The situation has turned for the worst. I did a bios update and power got cut. So bricked the mobo RMA’ing it just waiting for the supplier’s response. Once I get the mobo back I’ll try the suggested settings. The cards work individually (with their risers), if they are in the gen 4 x16 PCIe slot.



Got the Motherboard back unbricked.

I have tried the suggestions but still no luck.
Display set to PCIE2, disabled all extra features, tested each card and riser combo.

Found another thread with people saying with AsRock they turned 4g Decoding off.
That partially worked for me, now got 2 cards mining, But when I plug the last riser in the BIOS automatically enables 4g decoding and back to 1 card mining.

Final Update:

Got the rig to work.

PCIe Link speed: gen1
Adapter: OnBoard
Mutli-Display: Enabled
C.A.M Enabled
4g Decoding: Enabled

After spending a day on forums and on HiveOn discord, I decided to install windows and saw in device manager that the 3rd GPU had a code 12 error. The fix is was to change TOLUD (top of low usable dram) however with ASRock z590 Pro4 that setting is there, but instead I found someone else’s post asking to achieve the same thing and they stumbled across Clever Access Memory and that did the trick. After successfully testing Hive on flash drive, I flashed the SSD.

Glad you tracked down a working solution!

I have to say, I’ll be leaving that board on my avoid for mining list.

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.