More
referral
Increase your income with Hive. Invite your friends and earn real cryptocurrency!

OS Setup (Linux) Error: ACPI BIOS Error (bug) Failure creating named object

Hello everyone,

My name is Ricardo and I am trying to do GPU-mining on my computer. I recently ran into a problem during the installation of the OS on the computer.

I decided to use HiveOS to install the operating system on my disk and to use Linux. I flashed the image into a USB stick and connected it to the computer.

Bear in mind that the computer did not have any operating system before. So far what I did was to install the most recent version of my motherboard and change a couple of BIOS settings for mining.

My motherboard is an ASUS Prime Z690-P D4.

The settings on the BIOS that I changed so far are:

  1. PCI Express Native Power Management - Disabled
  2. ASPM - Disabled
  3. VT-d - Disabled
  4. PCIEX16(G5) Link Speed - Gen1
  5. PCIEX1(G3) Link Speed - Gen 1
  6. PCIEX16(G3)_1 Link Speed - Gen1
  7. PCIEX16(G3)_2 Link Speed - Gen1
  8. PCIEX16(G4) Link Speed - Gen1
  9. SATA6G_2(Gray) - Disabled
  10. SATA6G_3(Gray) - Disabled
  11. SATA6G_4(Gray) - Disabled
  12. XHCI Hand-off - Disabled
  13. Restore AC Power Loss - Power On
  14. HD Audio - Disabled
  15. Fast Boot - Disabled

My GPU is an NVIDIA GeForce RTX 3090.

The problem that I am currently facing is the following: the installation starts smoothly, but suddenly it stops with the following error message (see picture below):

“ACPI BIOS Error (bug): Failure creating named object”

I saw online on Reddit that I should on HiveOS disable the “GUI on boot”. I did that, it seemed more or less complete the installation but then on the computer (as I turned it back to “Auto”), it did not make the switch, still saying: “Warning: X Server (GUI) is disabled. NVIDIA overclocking will not function properly”.

Does anyone as an idea how can I overcome the issue and complete the installation of the HiveOS? Is there a way to turn the (GUI) back on, or I am doing it completely wrong?

I am super new at this and would appreciate your help.

Thank you and kind regards,

Ricardo

Does this drive work as intended on another system? You can test with the one you flashed the drive with.

Are you on the latest bios for your motherboard?

Does it have the same errors if you have all default settings applied for the bios?

1 Like

Hello Keaton,

Thank you very much for your reply.

Answering your questions:

  1. I have never used this drive before, it is completely new, but I flashed the drive through a laptop, so I don’t think I can test it on another computer once I do not have another.

  2. I am on the latest BIOS version of my motherboard - BIOS version 1402

  3. I have just tried again with the default settings applied for the BIOS and the same error shows up. The message: "ACPI BIOS Error (bug): Failure creating named object”, and then followed by a black screen with a “_” on the top left side blinking.

I will be waiting for your reply.

Thank you and appreciate the help.

Best regards,
Ricardo

Test it on the laptop

1 Like

Hello Keaton,

Thank you for the prompt reply.

To test it on the laptop I also need to re-flash the image for windows correct?

I flashed the HIVE OS image with the operating system as Linux and my laptop uses Windows. Can that be the root of the problem? Using Linux instead of Windows for the Hive OS image? Do you suggest that I install it in windows instead of Linux?

Best regards,
Ricardo

To test with your laptop just boot from the usb drive you flashed already. No need to do anything else. Just verify that hiveos boots and there aren’t any errors when booting from the laptop. It won’t touch your windows install or any of your files.

1 Like

Hello Keaton,

Thank you for your message.

So I turned on the laptop with the USB drive in but it does not run hiveos, it goes directly to windows log in.

The USB drive reads like a normal USB drive, opening the folder. I can’t read the .conf file in the laptop.

Should I try and flash hiveos again?

Best regards,
Ricardo

you need to press whatever button your laptop is setup to choose the boot device on cold boot, could be f8, f11, f12 etc.

1 Like

Hello Keaton,

Thank you for your reply. I am super new to this, so everything is a little bit harder for me once I do not have any experience whatsoever, so thank you for the patience.

My laptop is a Lenovo Ideapad 3. So I should boot the device in cold boot, and then what is the next step? Should I cold boot the laptop with the usb drive in it?

Once I cold boot it without the USB drive, the image that pops up is the following (see picture below). First, it asks if I want to “Shut down” or “Advanced Options”. If I click "Advanced [email protected] the menu that follows is the other picture.

I will be waiting for further assistance from your side.

Thank you so much for your patience in solving the issue.

Best regards,
Ricardo

you need to press whatever button your laptop needs to manually choose the boot device. its usually one of the ones i listed above. the pictures you posted are booting into windows, you need to press it before that.

1 Like

@ ricolivar did you manage to resolve the issue? What’s the fix?

The problem was on the USB I was using to install HiveOS. I switched to an SSD and it worked well. Hope you find this helpful

1 Like

Thanks @ricolivar