Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Only one GPU mines at a time

I’m running the current version of Hive OS (0.6-204@210608), Nvidia drivers 460.67 and T-Rex miner. I have 5 total GPUs - 2 x 3070’s, 1 x 2080 super, 1 x 1060 6GB and Quadro P2000 (5GB). Only the 2080 super is mining - the rest are detected, but that’s it (see attached). This rig worked fine in Windows 10 (but I switched to Hive OS for the convenience). To troubleshoot, I booted Hive OS with one GPU each and all of them mined just fine by themselves (staying in their own PCI-e slot). I tried ethminer and phoenixminer, all the GPUs together and solo and got the same result. Tried overclocking on and off, same result.

How do I get all the GPUs to mine in Hive OS?

You need the 455.45.01 driver for nvidia cards, or you need to change some settings in your mobo bios.

I just updated to 465.31 via the nvidia-driver-update command and same result (only one GPU mines). Windows 10 detected and mined all drives no problem, so I can’t see how it’s a BIOS issue (all I did was swap the Windows 10 SSD to this Hive OS SSD - made no changes in BIOS). I believe even NiceHash OS detected and mined all GPUs, just can’t overclock with that OS yet.

You specifically need the 455.45.01 driver. Check this post for directions

If that doesn’t work, make sure you have the following set up correctly in your motherboard bios.
PCIe Speed : Gen2 (For all the PCIe slots)
4G Decoding : Enabled
CSM Support : Disabled

1 Like

check riser power or conection

Installed 455.45.01, changed PCI-e speed to gen 2, 4G decoding is enabled, CSM support is disabled, Secure Boot is disabled… same result - only the 2080 super mines.

I ran “lshw -class display” in shell/terminal and see “configuration: driver=nvidia” for the 2080 super while the other 4 GPUs don’t have “driver=nvidia”, but just “configuration: latency=0” (these 4 GPUs are also labeled “UNCLAIMED”). I’m not sure why the 2080 super would get the drivers installed and the other 4 don’t.

Risers and power work just fine. They work if a GPU is installed by itself. They also worked just fine in Windows 10.

Usually this happens when secure boot prevents nvidia drivers to load but you say you disabled it. something is preventing drivers from loading. Maybe you need to delete all video drivers and update kernel to latest, then install the driver again.

secure boot prevents nvidia drivers loading for all GPUs or one and not all?

how do I delete all drivers? how do I update kernel to latest?

“sudo apt-get upgrade linux-image-generic” this updates kernel to latest version.
for the other stuff its a bit more complicated. HiveOs is linux so you can check in internet.

SOLVED! Heh, after hours of tackling this issue off and on over the last 2 months I got frustrated and tried another motherboard and BAM! - all GPUs are fully detected and are mining SMH. FYI, the motherboards in question is the ASRock Z490 Phantom Gaming 4 (old, problematic) and MSI MPG Z390 Gaming Pro Carbon AC (new, working perfectly).

Thanks everyone!

1 Like

Nice work!! Didn’t know mono change was an option haha. Knew it was in that piece of hardware tho!!

Your problematic mobo looks nice to me. maybe some special bios settings are needed .
Nice work. dont throw it away :smiley:

god is that all everyone says? check the riser?

Heck yea man, winning

we are all willing to help, based on our experiences. If you don’t like the answers, it’s your problem. i helps with good vibes

I had the same issue and also the Asrock motherboard. I had a feeling there is something to do with Asrock motherboard.

How to solving the problem?

Can you share mobo settings please? I cant get it to see more than 4 cards.

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.