More
referral
Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Nvidia Settings applied with errors

Im new to mining and as the title states I’m getting this error “nvtool failed by timeout error” or (exitcode=124) on 3 of my GPUs. I’m running 4 GTX 1060 6GBs(Will be 6 when I get more splitters) with an overclock of +150 core, +1200 Mem, and PL 90%.

Also my 4th GPU no longer shows up in hive idk what happened.

Running 460.56 drivers with an EVGA SC, Zotac AMP, PNY, and Gigabyte Windforce.

Any help is appreciated thank you

1 Like

Try to changing the miner and downgrade the driver to the version 455.45.01 (more stable for old GPUs)

type on the command prompt: nvidia-driver-update -l (lower case L)

Here I also always stop the miner before applying any OC changes and then, after the change is done I restart the miner again

1 Like

Hi, I have the same issue but with the code exitcode=1.

I updated the driver on the version 455.45.01, but it changed nothing. The OC setting work randomly 2 days ago, but when I have to do a restart I lost it and it doesnt work since. I’m with 4 1070.
Help !

Same her i s there solution?

Hello guys.
“I wasn’t mining for 2 days…” because of the driver issue which happened when I switched cards.
Please take a look…

Could you please share your ideas why “nvidia os failed” and why did these errors happen ?

  1. libEGL warning: DRI2: failed to authenticate
    (exitcode=1)
  2. libEGL warning: DRI2: failed to authenticate
    nvidia-settings failed by timeout (exitcode=124)

Here is my what happened. I have 4 rtx 3090. After fresh install today:

  • boot from USB, update the drivers via cli and plugging cards one by one
  • I set “optimum settings” for clock, power, fan (please see below)
  • It was working fine for about an hour
  • Then I touched (moved a little) the 4th card and it crashed.
  • I rebooted the rig
  • When it came up, I got “nvidia os failed”. Here is what inside:
    Wed Dec 1 20:40:43 -05 2021
    Detected 4 NVIDIA cards

GPU BUS ID : 01 07 08 09
CLOCK : 1125 1125 1125 1125
MEM : 2300 2300 2300 2300
PLIMIT : 318 318 318 318
FAN : 55 57 55 57
FANCNT : 2 2 2 2
libEGL warning: DRI2: failed to authenticate
(exitcode=1)

=== GPU 0, 01:00.0 GeForce RTX 3090 24268 MB, PL: 100 W, 390 W, 480 W === 20:40:54
SET POWER LIMIT: 318.0 W
SET GPU CLOCKS: 1125 MHz
Max Perf mode: 4
libEGL warning: DRI2: failed to authenticate
nvidia-settings failed by timeout (exitcode=124)

  • The hash is lower on these card 1 and card 2.
  • The power consumption is lower as well.
  • No throttling in the output from “nvidia-info”.

Could you please share your ideas why “nvidia os failed” ?

  • I managed to “fix” it only by decreasing settings to:
    CORE: 1100
    MEM: 2000
    With that settings cards give around 119.5MH now.
  • I increased core and mem to the initial settings of 1125 and 2300.
    They are giving around 121MH

Am I really the only one getting this error after the rig is rebooted ?
Guys ?

Hi guys, Did you figure out how to solve it?
I can’t set the fan speed with the overclok template. When I try to change it I get “Nvidia Settings applied with errors” (exitocode= 1 or 139). Then the fan speed remains on automatic mode.

Guessing you changed drivers from latest stable kernel?
Image 11-12-22 at 10.06 PM

Which kernel(#xxx) are you running? Lower right corner of web interface and no, this is not latest, it is one version behind:
Image 11-15-22 at 11.18 AM

Thanks Grea,
imagen

I tried to downgrade the OS and nvidia drivers. After having tried the latest dirvers (this didn’t work either)

Now, I’m getting this error when I tried to apply the OC settings: