Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Nvidia: Driver is not loaded error

I’m being unable to make the nvidia drivers work and I’m unable to upgrade them.

My rig was working fine with 3 GPUs. Then I added 2 more and one of the old ones stopped working.

GPU info:

[GeForce GTX 1660 SUPER] · EVGA
[GeForce GTX 1660 SUPER] · MSI < the one that stopped working
[GeForce GTX 1660 SUPER] · EVGA
[GeForce GTX 1660 Ti] · NVIDIA < new one
[GeForce GTX 1660 Ti] · NVIDIA < new one

I figured the rig needed an update, so I did. I honestly don’t remember the order, but I updated Hiveos version and the nvidia drivers version. All GPUs stopped working after that. As I had never updated and upgraded linux since the rig had started working (about a year ago) I did that as well (took quite some time). That didn’t solve the problem either.

I tried to downgrade both hiveos and drivers, that didn’t work so I upgraded both again. I was able to upgrade hiveos, but I was never able to properly upgrade the drivers. When I try to do it now it just takes a long time and then the hiveos shell times out (I did most of all this remotely). I’ve tried to manually upgrade the drivers too but the installation freezes while trying to uncompress the drivers package.
I’m not being able to make them work, and I get this error when I run nvidia-info:

Just adding the main error as text:
nvtool: error while loading shared libraries: cannot open shared object file: No such file or directory
Driver is not loaded. Only basic info is provided

How can I fix this and properly install the drivers?
On my lasts attempts I was trying to install the last version available (510.60.02). Please let me know if you have any recommendations regarding versions as well.

Extra info:

Z490 UD Gigabyte
2 × Intel(R) Celeron(R) G5905 CPU @ 3.50GHz AES
Hiveos version:
Currently “installed” nvidia drivers:

Any help will be much appreciated!

Try to do a full reinstall of the image of hiveos with:

hive-replace -s


have you done a fresh install yet?

1 Like

Thanks man! that worked!

For the people having this same issue: I connected remotely using shell-in-a-box and I just sent the command “hive-replace -s”. I had previously stopped the miner (just as a precaution, even though they weren’t working) but I think this was unnecessary, since the command then informed that it was stopping the miners too. It took some time but all went well (the command informs you about that and then displays “rebooting in 20 seconds”).
After that it didn’t start right away, so I selected “start miner” (again, this shouldn’t be necessary since you don’t need to stop them in the first place) and that was that. I didn’t need to reconfigure anything.

Thanks again!

1 Like

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.