More
referral
Increase your income with Hive. Invite your friends and earn real cryptocurrency!

NVIDIA A100 drivers

Heya.
Noob here and new to mining / crypto.
I have a gpu server with 2x AMD EPYC 7H12 64-Core Processor, 2TB RAM and 8 x A100 40GB that I am using from mining outside working hours when GPUs are not being used, however i could use 6 gpus’s non stop.
I have 2 virtual machines, each with 4 gpu’s allocated and windows 10. I have tried ubuntu, but i had difficulties installing the drivers, while windows was a straightforward driver.
One VM is mining on nicehash quickminer with a constant 169.52 MH/s and the other is with GMiner on 2miners pool. I get 175MH/s.
image

I am thinking about installing a dedicated OS, however does it worth the struggle? I see no support for A100 on hiveos, but maybe the drivers included already support it?

For the numbers given, i imagine I should have better results than now?

Thanks and my bad for asking maybe newbie questions.

I have a single A100 to test with. Still waiting on a server case to keep it cool. Have you tried booting the host to HiveOS? Curious to know if the A100’s are even detected?

Indeed a good cooling is a must, as the airflow is quite high, with an intake temperature of 19C and output of 65C, while GPU temperatures never go below 63 degrees C or over 70 C, no matter if indoor AC’s are full power and keeping a low 17C or 30C. The gpu is so efficient, that with 2 kW used we get 1400-1500MH/s and we spend only a few euro/day on electricity.

image

First of all, by no means I am advanced in IT. The server is virtualized using VMWARE and microsoft solutions. With tutorials I managed to make the A100 work in ubuntu and make it to mine, however after a few hours the miner stopped working with GPU errors. With windows10 I have no problems mining, so I stick to it.
I have tried installing HiveOS, but in order to create a virtual machine, I need an ISO file. With Hive .img, even if converted into .iso, it doesn’t start, so I can have some fun with the OS. With Ubuntu and Windows I cannot overclock the gpu, maybe hiveos is more flexible.
If you manage to install it, please let me know.

I would like to install at least 4 more gpu in the remaining slots, however 9500 Euro / A100 does not worth for mining.

Very interesting. Thanks for your response.
Not sure if you have physical access to the host server, and can interrupt whatever else is running on it, but if so you can try booting the server directly to HiveOS burned to a bootable USB. Might be an interesting test. I’ve read the A100 can’t use the standard Nvidia drivers… needs enterprise server drivers or something similar.
I’m looking forward to giving it a whirl once I can do so safely.

I have physical acces, as we normally use it for engineering , when rtx4000 on our workstations are not enough.
I will ask the sys admin about booting directly, however we have some VM I’d rather not reboot as we use them. Even virtualized we had serios issues with compatibility while mining and had to physically reboot a few times, which took a few hours to config again.

Regarding the drivers, we use datacenter drivers. I disabled the virtualization drivers, where we can split ca GPU on multiple virtual machines as that is something over my head to configure and I do not want to abuse the admin.
The superserver as it is called is a great mining machine, however it is not what was designed for :smile: , however in it’s spare time… why not :smiley:

Did you ever test this? Does Hive detect the A100 cards natively?? Thanks

I just finished outfitting an A100 with an EK water block. Connected it to a Rebtech mining MB and the A100 is not detected in Hive. Going to try it on a different Hive MB tomorrow.

Replaced the riser and the card was finally detected in Hive. This thing is a BEAST!


T-Rex doesn’t know what to call it, but Hive does:

I haven’t done any tweaking other than setting OP’s base OC. Not sure why, but when the A100 joined the pack, the 3060 Ti kind of freaked out. Can’t set the fan on it anymore - sits at 30%.

Hi Cowpen,

I have a similar setup to OCC, my server has HiveOS installed natively and HiveOS sees all the nVidia A100s just fine. However, I cannot get the mining to start. I’m just trying a basic Eth wallet with Ethminer, and nothing ever starts when I hit the rocket button(unless there is a different way to start the mining action), it looks like something tries to start but the GPUs just sit there doing nothing. Any suggestions?
Thank you,
-HowDoIDoThis

What driver version were you using to get HiveOS to see the card? It sees the card name, but the driver doesn’t actually load.

Hey guys,

So is the A100 compatible with Hiveos or not ?

Would be nice to know the results of your tests.

Thanks,
HB

Unfortunately, i did not manage to make Hive OS work with Nvidia A100. I am mining with 2miners on a Windows10 virtual machine for the past months.

Very good results, however it does not worth buying them if used solely for mining due to long return on investment. With 8 cards I consistently get 1.41 GH/s on 2 kW energy consumption.