More
referral
Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Nvidia 3070 Laptop Malfunction when 3+ Units

Hello,

Here are my current specs:
Motherboard: B85-ETH INTEL (5.6.5 03/31/2022)
CPU: 2 × Intel(R) Celeron(R) CPU G1840 @ 2.80GHz
Storage: Samsung Flash Drive FIT 64.2GB
Kernel: I have tried both 5.15.0-hiveos #110 and 6.1.0-hiveos #35
Version: Latest (0.6-224@231210)
Nvidia Driver: I have tried 495.46 through 525.125.06
GPUs: 3x Nvidia 3070 Laptop

I am running a 6x 3070 Rig and 5x 3060Ti rig on this same kind of board without issue.
The rig is able to detect only 2 GPUs at maximum and when entering 3+ then only first unit detected will encounter “MALFUNCTION” while all others will run as expected. I have changed GPU order, PCIe slots, and power cables to rule out those.

My assumption is that there is something wrong with the initialization within HiveOS itself for the board.
Units run as expected when I run a Rebtech 8 GPU board, what they were previously set up on.
This USB drive is reused from when it was on the other motherboard so perhaps I should do a fresh install and first time boot/setup would fix it?

Any insight on Linux commands to run? I’m presuming I need some equivalent of a PCIe fix/reboot/repair command to have it restart or recalibrate.

I can post images tomorrow / upon request as I will be sleeping soon.

Try the older 460 drivers if the laptop gpus arent working, if they are on the newer drivers then look at bios settings

Hello,
I went to try the 460 drivers however they are no longer in the compatible list for the latest mentioned kernels.
Which Kernel/Version should I downgrade too that is the latest which still supports those drivers?
I will check the bios settings, is there anything in particular I should be looking for aside from the typical 4G Decoding?

If they work on newer drivers theres no need to try older ones. Do they? (Even if only 1 by itself)

Correct,
Devices were working on newer Nvidia Drivers both on a prior motherboard and when less than 3 GPUs.
I know that 3070 Laptop used to have issues where you needed to start at Driver 460 and work upwards, but I thought that had since been fixed.
I will be poking around in the bios again later. I will see if any other motherboard options aside from 4G Decoding stick out to me.