More
referral
Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Not able to mine on NVIDIA A100

I have connected one A100 and one A5000 to my system. Hiveos detects both but always fails start mining. I am able to mine with single A5000.
Seems A100 drivers are not loading?

  1. It shows some ‘unregistred device…’ prints in beginning.
  2. X server fails to start
  3. On miner screen I see - Cant initiliase cuda engine. Is NVIDIA driver installed?

I have flashed [email protected]

Anybody tried A100? Thanks.

have you tried the latest stable? what driver?

Yes. I have tried latest stable. Current driver version is 470.63.01.

That driver doesn’t specifically list support for the a100. Have you tried 470.82.01? Nvidias site points to that driver when selecting that card.

Ok I will try it. Any guidance on how to install it on hive?

In shell type nvidia-driver-update 470.82.01

Driver installed successfully but still I see issue.

Log snippet:

t-rex exited (exitcode=1), waiting to cooldown a bit

Skipping miner log rotation due to execution time < 30sec

20220104 01:10:46 ERROR: Can’t start T-Rex, can’t initialize CUDA engine, cuda exception: CUDA_ERROR_NO_DEVICE. Is NVIDIA driver installed?
20220104 01:10:47 T-Rex finished.

can you post a screenshot of your worker overview screen?

I did hive-replace to latest stable image - [email protected] · Latest Stable · K 5.10.83 · N 470.86 · A OpenCL 20.40-5.11.1001 · Dual-Boot / Image with support for latest Nvidia GPUs and AMD GPUs.
I see display is not getting up with two GPUs. Only A5000 works.

As per Hive OS Upgrades | Hive OS, A100 support is added after [email protected] This image or later I am not able to get.

  1. Can you please help getting A100 supported image?
  2. Are there any bios settings I should be taking care?

Attaching screen shot after booting on shell, since native display is not up with two GPUs.

how do they show on the driver nvidia lists support with? 470.82.01

Ok. Not sure.
But as per Hive OS Upgrades | Hive OS, A100 support is added after [email protected] This image or later I am not able to get. I will try latest image as last try for A100.
Can you please help in getting image after [email protected]?
Thank you.

What’s your current config? What kernel/hive version/driver version? A screenshot of your worker overview will have all of this info.