Increase your income with Hive. Invite your friends and earn real cryptocurrency!

No GPU available for mining

Hi all,

First of all i m newby here and mining.

I chekced forums but cant found answers for my problem. If there is one pls let me know.

My system is;
MoBo : Gigabyte A320M-H
CPU : AMD A8-9600
GPU : RX 550 4gb
COin : Raven (RVN)

My problem is;
Once i start my mining program in Hiveos(also in windows mining with NBminer, lolminer etc) i got error as:

  • Error resolving function: cuFuncSetAttribute
  • Devices initialize failed.
  • No GPU available for mining.
  • Mining program enexpected exit.
  • Code: -1, reason: Unknown error

I have never mined, i got GC recently. Also uploaded my problems photos below.
How can i solve this problem? Please let me know

Thanks beforehand

Use Windows… no sense in running HiveOS for one RX550.

Why are you doing it anyways? This dude says you’ll get a “whopping” 23 cents a day in USD,

AS i mentioned before, i already tried and got same error message.

Once i start my mining program in Hiveos(also in windows mining with NBminer, lolminer etc) i got error as:

cuFuncSetAttribute is a CUDA error.

AMD cards do not use CUDA.

Looks like you’re hitting the same issue as several other AMD 4xx/5xx users

Any Luck yet ? I have the same problem for 1 week now. I have 6 RX 550 4GB, trying to mine Ravencoin on HiveOs. I tried NBminer & lolminer (error same as you). I tried TeamRedMiner (error dead GPU detected), I tried Gminer, Bminer, basicly every software that supports AMD GPU, No luck (all of them gave me many types of errors). At this point, I’m giving up :sweat_smile:. I tried every single one of them on Windows 10 too. Results are the same.

UNfortunately no good news.

but, not give up yet. WHat is your MoBo?

Have you tried a single card in the motherboard’s x16 slot?

My Motherboard : Biostar TB250-BTC

Not yet, I’m gonna try it later and update here. Thank you :grin:

I tried that - -

Now, i can mine ADA with unmineableminer but still get same error with NBminer (for RVN mining).

Before doing above changes i cant mine ADA too.

Edit: Now, tried unminableminer with RVN, and i get 10,5mh for it. But same error with NBminer.

weard :confused:

Sorry, I got nothing good to update, I tried a single card on MoBo directly, still gave me an error for teamredminer and NBMiner. So I currently mining XHV for 300H/s each with Teamredminer on HiveOs. (somehow Teamredminer works for XHV, but 'dead GPU error for RVN)

it’s been a stressfull day, I tried to unplug my USB (containing Hiveos) and trying to boot up windows, but my windows won’t boot. huff :disappointed:. At least I still have my GTX 1070 mining Doge on Unmineable.

Wait, you are able to mine raven on Unmineable ? with what software if I may ask ? is it 10Mh/s on EThash (>4GB GPU), ETChash (>3 GB GPU) or Kawpow (>3GB GPU) algorithm ?

perhaps it’s time for us to sell these RX 550 for an 8GB GPU card :sweat_smile:

1 Like

10,5Mh/s with High - Etchash
8,8Mh/s with Low - Etchash

10 MH/s etchash with rx 550 is impressive, Nice man !.

do you OC or bios modded the gpu ? I tried ETChash unmineable with RX 550, didn’t flash the bios, and only got 7.8 Mh/s top.

Currently, My rx 550 give me around $0.55 per card. (on XHV)

No OC or modded bios. but - IDK if its relevant - i use radeon blockchain software.

after i update and patched - you can see how should you in above message - i can mine RVN with 10,5mh.

Also, i think its not about 4gb, as i see in other forums, some amd 8gb GPUs get same error - or sth like us- (see, new miner doesn't work with SAPPHIRE Radeon RX 580 Series 8GB: · Issue #28 · develsoftware/GMinerRelease · GitHub)
i checked it with GMiner in Hiveos and get same error with my 4gb Rx550.

and also, seems like it depends on the algorithm of the coin. With Teamredminer on RVN (kawpow), my GPU was detected dead. But if i switch the coin to Haven (CryptonightXHV), Teamredminer run smoothly. Haven’t check with NBminer yet. Hmm.
well, I sold 4 out of 6, of my RX 550 to my friends already, hoping to find used RX580 8GB on the market.

Not sure if you got this resolved yet, but if you look at your GPU in the picture, it doesnt see your GPU BIOS, (xxx-xxx-xxx) you will most likely need to update your BIOS on you motherboard, If your 580 has the dual bios flip the switch, did you buy it new? or used? it could be modded wrong too but doubtful. but I have many 480/580’s running on both ETH and RVN. mine work fine on NBminer and HIVEos

Thx for comment. However, BIOS already updated before setup. Also, its new but some old cards (which already mined) same problem.

I can mine RVN with Unmineable, but cant with NBminer, phonexminer and some others.
And i can mine ETC without problem with Lolminer via Hiveos.

Dont know problem yet, but sure above its as you said.

thanks anyway

hey did you ever get this figured out?


i can mine other coins (etc, trtl etc.) but not RVN.

Why so? God knows.