More
referral
Increase your income with Hive. Invite your friends and earn real cryptocurrency!

No Display on Monitor

Appreciate the insight, but downgrading the OS can potentially trade one issue for another.
Losing the ability to use an external monitor isn’t a deal breaker; just a “nice to have” and personally, I’d rather not lose other/more current features between those versions. Glad it’s working for you though.
I think the trick is identifying what specific configuration is different between those versions, causing the function to work as expected.

I didnt say to downgrade os.

  1. Make clean install of older version.
  2. upgrade to the latest version. Done.

Well, you were talking about going from a current version, to a previous version. Which in my case, since I’m using [email protected], would be considered as a downgrade.
But, the semantics aside, you hadn’t mentioned anything about “upgrading” to later version after (clean) installing v208.
In the software world, it’s not unheard of that going from one version and then incrementally increasing to another can resolve some conflicts. So it might be worth a try. Thanks!
Though, I’m still curious about other resolutions on the issue and would welcome additional perspectives.

Oky you are right about that. So you can try first on a usb stick and you will se if works for.you too… happy working.

1 Like

Which version did you fresh install ?

V. [email protected]

I am having the same issue. Just built a fresh rig, no GPUs connected. Worked great on V. [email protected] I tried to upgrade the rig, and after booting, the same older version was showing. I did a force upgrade to [email protected] and now the rig comes online, but doesn’t show anything on the monitor after the initial boot

Have you tried anything with the settings in the bios? Maybe bios update will help?? Which motherboard do you have?

Yes, I tried various integrated graphics options but nothing worked. It’s an MSI B450 Gaming Mobo with a Integrated Graphics Radeon CPU.

You have disabled csm and set pcie to pcie gen2, enabled 4g decoding?

But i think that is a problem in hiveos. Try to make a clean install of version V. [email protected] and then
start hiveos in maintance mode. Then upgrade hiveos to 1 newer version, and see if works for you. If works then upgrade with 1 newer version and so on.

So upgrade from V.@210818 to V.@211104.

Same here, MSI B450 GAMING Plus MAX
HiveOS [email protected]
Disable CSM, Enabled 4G Encoding.

Having the same issue, won’t go past the blue screen. And it’s happening on the two new ones I am trying to set up. Last week done another 2 with the same MSI B550M-A PRO and had no issues. I am using a cheap gpu the gt730 but if i try with a 3060ti I don’t even get video at all.

I believe I tried all the suggestions
On my motherboard the B550M-A PRO

  • Above 4G memory /enabled
  • PCI_E2 Gen Switch/GEN2
  • UEFI set mode by default

Re-flashed 0.6-208 but stays at the blue screen.
Also set to ignore gpu but doesn’t go past the blue screen.
Also recovery don’t work.

Seems a lot of people have the same issue but no real solution.

Try with version V. [email protected] and then upgrade to version V.@211104 and then report if it works. In this way ive solved a problem.

Hi Mals

I have a very similar setup to you. Did you find a solution? All looks good in the HiveOS app but no video on the rig HDMI monitor. Rig is performing well.

MB Z590-P
CPU I5-10400
GPUs AMD 6600XT
Using latest Z590 BIOS
BIOS Settings:
VT-d = Disabled
IOMMU Pre-Boot = Disabled
Primary Display = CPU Graphics
PCIEx16_1 Link Speed = Gen1
Above 4G Decoding = Enabled
Launch CSM = Disabled

Hello Easy, found any solution on this? I’m having the saem issue. Thanks.

@Skeezy

I found the following post on HiveOS team testing the TZ590. Pretty clear that the current HiveOS Linux version does not support Intel integrated CPU graphics found on Z590 motherboards. Too bad. The suggested work-around is to plug the monitor into one of the GPUs. Not great.

But I have tried to use the HiveOS web app menu item “Remote Access” at the top of the page, with either the HiveShell Start or Shellinabox menu items. With these you can at least use the “miner” command to watch the miner running from your browser on another computer. There are several other helpful commands listed in the shell when it starts up. Unfortunately, if your rig is down or locked up, these remote shell commands do not help.

Hoping that HiveOS / Linus can handle these newer motherboard chipsets soon. Z590 and TZ590 boards so far appear to be more stable.

2 Likes

New here, but I have a temporary solution that will help I think. So the issue I found is that my boot device go splintered, I think. Not really sure. The temporary solution I found for troubleshooting is as follows.

After initial boot, shutdown and restart.
On second boot, enter bios.
When I did this, I noticed my initial boot drive had been set to “UEFI” at the full capacity, but my OS was separate at the boot drive capacity I had made (a bit smaller than the full capacity of the SSD).
While in bios, I opened the boot menu and 2 drives were listed I clicked on the smaller of the 2 options and the machine booted and went through the boot, blue screen, and ended up in a full boot with cursor.

I’m not sure if this is a fix, but it did reenable my display within hiveos.

Hope this helps.

Jim S.

1 Like

This helped me to fix my issue with the HMTech 7" display. I have 6 AMD GPUs and by setting “GUI on boot” to “GUI disabled” in worker settings, the monitor is now displaying after shutdown and boot in 30 sec.

I have a similar set up to you. with the same mobo. hive os says my internal graphic are disabled. I’m running the latest os version. CSM is Disabled and 4G Encoding is also Enables.

Any thoughts on where I should start?