Increase your income with Hive. Invite your friends and earn real cryptocurrency!

No-carrier / "wifi setup done. No Connection. Check settings and try again."

I am trying to start my first boot. I use command wifi. Pick my network name. Put in the password. Then it says under state

State: no-carrier no-carrier no-carrier no-carrier no-carrier no-carrier no-carrier no-carrier

then at the bottom it says

wifi setup done. No Connection. Check settings and try again.
If you will not use WiFi please disable service later with command wifi-disable

I have no clue what do to. I have tried resetting my modem, creating a new guest address, using the hotpot on my phone, switching USB ports, resetting my rig.

Is there anything I can or should do?


Problem solved, not sure what happened, but it started working

Ok problem is back. Wifi worked for like 8 mins and now it won’t work.

У меня аналогичная проблема, только картина интересная. Я решил перенести систему с SATA HDD на NVME размером 15 гиг.

Решил установить заново, конфигурация всего кроме накопителя точно такая же, вайфай точно такой же на базе rt2800usb, который работал до этого года 3 наверное на этом же ящике под этой же осью.

Короче говоря я устанавливаю с нуля, разворачиваю образ, загружаюсь запускаю мастер настройки получаю тот же no carrier. Как я не пытался играть с настройками системы и драйверами и блеклистами, без толку.

Вставляю назад HDD с системой которая работала еще сегодня утром - все работает.

Ну думаю сделаю копию по разделам через DD c HDD на NVMe - сделал, после перезагрузки тоже самое, пишет уже на настроенной системе wlan0 no-carrier rt2800usb запуске

и сеть поднимается только если запустить wifi SSID PASS или прописать эту строчку в

параметры сети и сид при первоначально настройке записаны правильно и не пропадают после перезагрузки, но все равно запуск сети возможен только после команды wifi SSID PASS

какая то бредятина

уточнение, в качестве nvme использую MEMPEK1J016GAH

Got the same issue the past few days when we migrated from sata SSD to NVME. I could connect to wifi with “wifi SSID PASS” but the system itself was not able to catch an carier during the startup.

Even though I passed this command to the rig connected to the net but mining did not start automatically. There are several problems calling “miner start” in so I decided to refuse that.

I found an elegant solution which worked for me and the rig can connect to the net successfully and also starts mining right after that. No messing up

Solution is to create wlan0 under the following path:


With the following content:

auto wlan0
iface wlan0 inet dhcp
wpa-ssid {MY_NETWORK}
wpa-psk {hashed-value-of-passphras}

You can get the hashed-value-of-passphrase via the output of:

wpa_passphrase MY_NETWORK passphrase

Originaly user thinh posted this method here.

I bought the wifi extender (tp-link model number TL-WA850RE) and connected an ethernet cable to it. This solved my issues completely with firewall, couldn’t connect to api, curl issues and more. tp link TL-WA850RE

Hi. I’ve created such file with my parameters and hash and still nothing work. So i’ve returned back to old hdd.

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.