Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Newbie miner with RX-5700 GPUs (SOLVED)

Hey all, I’m trying to setup my first rig using MSI RX-5700 MEC GP OC cards. I installed the latest version of HiveOs available from the farm, used Etcher to burn the image, all went well BUT after I setup to mine (wallet,miner,etc) the miner Claymore Dual fails to start and the rig just says “Error” in red. One the actual console I see ‘amd-info’ there are no AMD GPUs to use. After googling a bit I found a post that says RX-5700 is only supported in the BETA. So I downloaded the BETA,burned to same ssd but it will not boot. I just get a GRUB prompt, no menu at all ???

Can someone point me in the right direction, do I really need to use the BETA version?


Yes, it’s true. You need BETA instead STABLE to mine with RX 5000 series

Current stable contains AMD drivers 19.20 that not supported AMD Navi cards ( RX 5x00 series)

1 Like

Thanks for the verification… My problem turned out to be Etcher with the BETA. After 3 burns with the same result, I decided to try using DD on my iMac since that’s how I burn my other images and what-da-ya-know…it works fine. A bit puzzled because Etcher works fine on the stable GPU image ???

Thanks again…

What about the 19.50 versions? I’ve been struggling all day and night. During the driver install is fails saying dkms kernel failed during build or something

I “WAS” using MSI rx-5700 MECH ( which probably means crap in Chinese) cards and I tried ALL options of BIOS editing, XT BIOS, etc. I managed to get about 54 MH/s out of the cards but the GDDR6 temps shoot quickly to 102C then 104C and the miner (Claymore) shuts down cause it can’t find any GPUs. These things are heaters (learned that too late from google posts).

The cards where still under the 30day return period at B&H, so I returned them.

I bought 3 GTX 1660 SUPERS to try but have not had time to play with those yet…

Good luck in your RX-5700 endeavors…

so all this time i been freaking out why my 5700xt cards would not work was all i need to do is download beta ? lol why don’t they warn you of that at all ???

hi guys
i also try to mine with my new rx 5700.
hiveos know the card, but no miner will mine with it…
tried with claymore, phoenix and teamreadminer…
i don’t see any errors or something bad.
could someone help me?

hiveos [email protected] beta with the amd 19.50 driver…

Hi, you just need to burn the [email protected] Beta version that includes the correct driver for Navi cards (RX5000 series). Good luck!

I have two rigs of 6 cards each and I can’t get more than 51MHS for one card. these are my settings. when I increase the values, the miner always restarts. Please help

Have you done the VBIOS mods?
Those memory temps seem particularly high for those settings too.
What is the ambient temp?

I haven’t done VBIOS modes and I don’t know how to do it. The room temperature is around 30 C

This video will walk you through how to do it.

Its pretty straightforward and should yield better results