Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Navi 23 [Radeon RX 6600/6600 XT/6600M]

hello, I installed two AMD Rx 6600 xt cards in my rig.

both are displayed as Navi 23 and do not mine.

What can I do?


I had same issue with newly purchased msi rx 6600 xt mech 2x, navi 23. Just prepare new usb with latest image. After booting perform self upgrade. And reboot. Now mining perfect.

I have 5x Sapphire Radeon RX 6600 XT and 1x MSI Radeon RX 6600 XT.
Tried on latest release, MSI card is mining ok, but identical Sapphire cards are showing as Navi 23 with AMD OC failed and don’t mine at all. I managed to mine on Sapphire cards only once, but after reboot they became Navi 23 with no mining. Tried to downgrade, but with no luck.
What can be wrong with Sapphire Radeon RX 6600 XT cards?
Thanks for answers.

Attaching last good config with Sapphire that was mining before reboot.
I tried to recreate all conditions, but still all Sapphire cards are Navi 23.

Hi !
Have you got any update about this?
i just asking if buyin’ a MSI Ventus 6600 or a Saphire Pulse 6600

for what i’m reading i will choose msi!

Still can’t figure out what is the real problem.
So far, I have the following:

But after the next reboot …

Then after reboot it was again Navi32… and after tuning everything is ok again


I am getting the same error. Just created a new rig with only AMD cards. I tried TeamRedMiner and NBminer so far.

I am running an ASUS TUF B550-Plus mobo. This error has to do with OC settings. Everytime it appears for me, it says AMD OC failed…

Sometimes on restart it fixes itself. But then I’ve restarted it 3x in less than 20 minutes and I get NAVI23 for my cards. In addition, I have my fans set to always run - when I get NAVI23, my fans don’t run… I am also using a riser splitter…

You all are not alone!

Okay, I got some results last night. I had to go into the BIOS settings and change the PCIE16_2 slot to accept 4x lanes. I am using a a Riser card adapter on my 2nd PCIE lane to accept 4xGPU risers. A 6 GPU total setup.

At first, I tried and tried and tried to get it to accept it with 2x GPU plugged in my Riser card adapter, but no luck (on reboot, it sometimes accepted it, but then the NAVI23 issue came up too). Basically, the mobo is too smart for it’s own good and wants to auto config every PCI lane for something (and not GPUs). You have to go in and mess with the BIOS config depending on your mobo settings.

This youtube helps to show you what to look for.

Once I switched my PCIE_2 to 4x and changed the setting to “GEN 2.” The computer recognized the Riser adapter and recognized five cards.

Now, I still have issues with my last card witch is plugged into a PCI slot. But 5 recognized cards is better than a bunch of NAVI 23!

It was all BIOS issues for me and my motherboard. I got worried when I first tried switching the rig over to 1x speed (it stalled the first time). But I got it all setup.

Also, I will suggest to reset your BIOS, run 1 GPU and make sure it works. Then add another GPU, and another and another.

ASUS B550-Plus Bios Settings: 4G enabled / Gen 1 PCIE / 1x PCIE for all slots.

Hi nightrider77, I was getting random reboots with “Navi 23 blah, blah, blah”. Back off your OCs a bit (MEM especially) and it should stop.

Anyone already using the RX 6600M on hiveOS?

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.