Increase your income with Hive. Invite your friends and earn real cryptocurrency!

My ASIC farm is going offline but actual miner are working perfectly fine

Each time offline lasts for 4 hours and automatically comes back online. The whole farm. What is wrong with this API thing? how can I solve it? Please help me out.

If you have any hive gpu/cpu rigs you can run ‘net-test’ in the shell and take note of the best performing api servers to your location, then try some of those api servers instead of the default as there may be some issue between your machines/isp/api server that will be resolved by choosing a different api server mirror.

1 Like

Thank you for your reply. I am only running ASIC miner and where can I find this shell and run the script of net-test? sorry I tried so many things and still couldn’t find that shell thing. :smiling_face_with_tear:

Youd need to ping each server manually and see which returns the best results. You can find the list in your workers settings → mirror select.

If your asic is losing hashrate during these notifications it looks more like a network/internet issue instead of an api one though

1 Like

Dear Keaton, I took your advice and managed to Ping each API server and found out that a good API for my region is So I changed all mirror select and made the change, but nothing happened. When I tried to add a new ASIC miner to my farm, it said
this failed to register device WorkerAPI - failed to send request: Post “”: dial tcp connectex: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. (server:

why i am still on Paris API? I changed everything mirror select to api ru now I am lost again and everything is offline. Please help me out. :smiling_face_with_tear:

Did you change it on your asic hub settings?


yes i did that too.

Try rebooting the system with asic hub installed?

1 Like

YOU ARE THE GENIUS and the biggest help all the way. I wish I could hug you right now. After rebooting my laptop, all back online, and now I can add my 2 x K7 Miner to the rig. Love you sooooooooo much Keaton. You are the best and You are the man. Thank you thank you thank you. I spent all night to figure it out with your help. This is totally worth it. :smiley: :smiley: :smiley: :sparkling_heart: :sparkling_heart: :sparkling_heart: :sparkling_heart: :sparkling_heart: :sparkling_heart:


No problem man!


Dear Keaton, My man

 Now I am facing a new error on the hive. I did change the API to ru-cf and rebooted the system but still showing offline on hive OS. I am trying to set up a brand new Beelink Mini PC for the remote control. Followed up by SS.