Increase your income with Hive. Invite your friends and earn real cryptocurrency!

My AMD Ryzen 5 5600G is not recognized as a CPU but as a GPU

Has somebody run into this problem before?
I’ve setup my rig for dual mining, GPU for ETH and this CPU AMD Ryzen 5 5600G for monero.
But in the dashboard the CPU is shown as an unknown GPU, still it does mine. But I would like to see the statistics as well, and now it does not show that.

does your bios allow you to disable the integrated graphics?

Yes it does!

Hi, after you disabled the integrated graphics in bios, did it work?

The igpu of 5600G is still recognized as “unknown gpu” in my hiveOS… even after I disabled it in bios.

Please help!

Okay I fixed it by specifying the device(s) to use in HiveOS flightsheet settings.

Hey, Indeed it didn’t help after I disabled integrated graphics.

How did you do that precisely? Are you still mining on the CPU?

Yes, I’m dual mining ETH with GPU and RTM with CPU.

My problem was: I did not need the integrated graphics of 5600G to mine ETH (it could not). So I just specified these 2 3070ti’s and excluded the “unkown GPU” in the miner’s config.

But your question sounds like “how to see the statistics of the 5600G”. If my understanding is correct, then I do not know… As shown in the picture, I can see the statistics of CPU mining, but I cannot see anything like “5600G” either. It just appears as an “unknown GPU”.

I’m having the same trouble. It appears as though when I setup the rig (which has no OS, running entirely off HiveOS from the ssd and no other GPU inserted) it shows as “GPU 0. Unknown GPU xxxx 512 MB · AMD/ATI” on the farm overview screen.

It appears to be mining but at a much lower hash than expected (500/s).
My guess is that the inbuilt graphics are triggering HiveOS to see ignore the CPU as a mining chip and only seeing it as a low end GPU.

To the OP’s Q and now mine also - is there a way to either disable the onboard graphics to trigger hiveOS to recognise the CPU via bios or somehow set it up through HiveOS?

If your IGD appears as the last “GPU” on your HiveOS API screen, have you tried lowering this value by on under your Rig’s settings page? This would effectively exclude this last device from your HiveOS API screen…

In my use case, I leave it on and mine Ton on the 5600G IGD. See below:

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.