More
referral
Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Msi Z390 A PRO with 11 gpus and not accepting 12

Hello,

I’m currently running a rig with a msi z390 a pro successfully with 11 gpus

The pci slot mapping are :
1: PCIx16 → splitter 1 to 4 : 4 gpus (4xriser)
2: PCHx1 → 1 gpu (riser)
3: PCHx1 → 1 gpu (riser)
4: PCHx4 → splitter 1 to 4 : 4 gpus (4xriser)
5: PCHx1 → 1 gpu (riser)
6: PCHx1 → empty

My bios is set up and i disabled audio + serial + parallel, video set to IGD and screen on motherboard DVI port.

Unfortunately when i plug my card #12 it does not work (i’m not even seeing the bios … i got a black screen)

Did some have managed to make it work with more than 11 gpus and how ? I believe I ran out of pci lanes (This topic is hard to fully understand and gave me headache about pci / pch , cpu and chipset max lanes , why the 1 to 4 spliter has a x1 form factor -will sound logical it have x4 form factor as it split x4 to four x1 lanes …).

Anyway if we have some expert on the topic I would like to know if trying to disable usb in the bios could free some pci lanes (this means I should buy a ps2 keyboard and migrate my hiveos usb dongle to a sata ssd) ? other option is to disable sata but it seems not possible on this motherboard (no option in bios) … btw i was unable to find a block diagram to know if my m2 x4 port (currently unused) is PCI or PCH -this could be a third option to add gpus-

Thanks for any advise on that :slight_smile:

Olivier

and here we go, you have successfully connect 11 GPU with msi z390 a pro, some user / people were having a problem connect to 6 GPU with this motherboard

:sweat_smile:

try to set IGD to external GPU Display to free up some PCIE-Lanes

I have same Issue, was able to connect 11 GPUs tried different setting but 12th won’t connect, using HiveOs on MSI Z390-A PRO, I have same problem with MSI Z590 A-PRO only 11GPUs works after connecting 12th it will not boot to bios or to HiveOs, Z390 white LED will lid as no graphics available nothing different on Z590 just wont go to HiveOs or bios. If you have any luck please post that. I will keep playing around as well.

Hi . what CPU use you for this configuration?? thank you

Hey.
I Have the Z-390 A-Pro Board
an by me works it fine with 11 GPU´s
I Have the I5 9400F
4x 6600XT 7x 6600

333 Mh/s 564 Watt

Hi thank you.
Where do you connect PCB 1pcie x4 USB?? In pcie x1 or x16

Thank you

Hey
on PCI_E1 are the first GPU RX6600 direct on the Board for Monitoring
PCI_E2 empty “the GPU from PCI_E1 are over it”
PCI_E3 the First 1 to 4 PCI Riser Adapter
PCI_E4 the second 1 to 4 PCI Riser Adapter
PCI_E5 Riser direct to the GPU
PCI_E6 Riser direct to the GPU

i hope i can Help You

Man I’ve been using this board for a while. Running 8 cards no problem with the i5 9400f, using two m.2 to pcie converters. Was hoping to get 12 on this board using pcie splitters. So no one is getting past 11?

Actually i didn’t saw anyone going above 11 gpus.

But I have a few ideas to go above 11 that could work.

  1. Disabling USB may free PCI lane (at least 1, maybe more). It means that you should disable it in the bios, taking care that usb won’t work (so use a ps2 keyboard, and put hiveos on a sata disk -no more usb stick-)

  2. I guess (but not expert) that PCI lane (cpu) and PCH lane (chipset) are limiting the GPU count. PCI lane are 16 and are available on the first PCI express slot (the main one). Using a 4 card splitter on it will make 12 not available … so i think technically if we can plug 16 gpus on the main pcie slot we could go to 23 gpus … but hardware is very expensive to do that (it’s cheaper to build another rig). However I found a cheap 1 to 6 splitter that could be used and add 2 more cards so a max of 13 gpus.

Up to you to test those ideas and give feedback.

This is the 1 to 6 splitter I saw. I have one and confirm it workds, but did not tried if it could push the MSI Z390 A PRO to 13 cards.

1 Like

Hello! what is ur settings on bios? i wanna to install my 5th gpu but cant’t .Help me pls :slight_smile:

Hi,
Did you tried this setup? I am following same steps….
If you did, what was the outcome?
Thank you

Hi.
Can you show all the bios data in the msi z390a pro?
Thank you

Hi everbody.

I have same problem with MSI MAG Z390M Mortar so i would like ask in case of somebody can comment or already solved this problem.

Virtualization Tech, sound card are disabled, Gen2 was selected, 4G is enable but when i add 12th GPU card, MSI MAG Z390M Mortar red light is lid and only black screen is appeared (not boot). I am using i5-9600K (Max Supported PCI Express Lanes is 16)

I have 3 PCIx slots on motherboard.

PCI_E1 (CPU lanes) x16 → 1 to 4 pcie cards is used in order to connect 4 GPU.
PCI_E2 (PCH lanes) x1 → 1 to 4 pcie cards is used in order to connect 4 GPU.
PCI_E3 (PCH lanes) x4 → 1 to 4 pcie cards is used in order to connect 4 GPU.

If you can comment, i will be happy.

Thanks.

Hi again.

I have changed mobo and cpu with Gigabyte A520M S2H and Ryzen 3 1200 AF. It works with 12 gpus.

Thanks.