Increase your income with Hive. Invite your friends and earn real cryptocurrency!

MSI RX 570 ARMOR 8G OC need help with bios modifying and overclock for low hash rate


This is the first time that I am doing bios modifying. I might not know a lot of things or I maybe did something wrong. Bare with me please.

I just got a second hand MSI RX 570 ARMOR 8G OC card.

Used following software on Windows OS.

  • Used PolarisBiosEditor and One Click Timing Patch. Software asked me to apply best settings for Micron memory and I accepted.
  • I uploaded modified bios on card using amdvbflash and everything was good.

I did not test its before/after MH rates and directly put bios modified card on my rig.

My current values are way lower than any other RX 570 card I see in the forum. I only get 19.22MH out of it and that is with over clocking.

Details are as following:

NOTE: amdmemtweak --REF 0

This settings are something I picked up from a preset and modified slightly using another RX 570 that I saw in the forum.

Below is my stock bios timings

Below is my modified bios timings

Anything over 1500 and up is same

I wonder if there is anything that I did wrong so that card is not mining around 30MH

Any help is appreciated.

Thanks & Regards,

It turned out to be an over clocking problem. Seems card is actually bios modified successfully.

My working settings are as following.

You should improve more the OC. I am with Asrock RX 570 8GB Samsung and with my OC i get 97W and 29.16 MHs. 51 degrees C Temp and 47% cooling. your cooler is at 100% and 100W to get almost the same MHs.

my Core clock is 1165, Core Voltage 850, VDCCI memory controller voltage 800, Memory clock 2180, Memory voltage 800, Fan speed 50%, Switched on Aggressive undervolting, amdmemtweak --REF 200 setting.

do you have vbios flash file… can u share…
msi armor rx570 8gb samsung memory…

Sorry i dont have. My card is not bios modded. What you can do is get your bios directly from your card. This is done in hive os flash bios tab. You have an option to backup your current bios. Then open it with polaris bios editor, and then one click timings fix and then flash it back but keep the stocked backed up somewhere. I didnt want to mod the bios because it voids warranty. I currently make 29.29mh/s

Hi, it’s my first time posting here.
I have a RX 570 MSI Armor 8gb. Initially i was doing about 20.5 MH/s. After I downloaded the vbios in techpowerup site (link: VGA Bios Collection | TechPowerUp) my card’s doing 28.45 MH/s without bios mod from polaris (when i make bios mod the card does not work i don’t know why), but it’s a good value

Dude, you never download bios from other sites unless its absolutely needed. What you needed to do i save your stock bios by extracting it from your GPU directly. Thats easily done from the overclock tab in Hive os , there is a download vbios button. you save it in your computer and then with polaris oneclick you modify and save it under other name so you can have both original stock bios and modified one. You flash the modified bios then. keep in mind that you need to stop miner and card should be working when you upload new bios.
I have a similar card , Asrock but with the same samsung memory. i moded my bios recently and used it. with settings 1112 core clock , 825 VDD, 800 VDDCI and 2100 Memory clock it doesn 30.17 MH/s with 90 Watts. I guess my GPU is a bit worse than yours since it consumes more power but you should be getting more or less the same.

I used polaris correctly (i bios modded my rx580 and went ok) but my rx 570 simply does not start when I upload the modded bios. I tried version 1.7.5 and 1.7.4, uber mix 3.1, 3.2, 3.3, does not work. After it I just gave up :frowning:

Are you using the same oc settings ? After bios mod you should start over. Lower the mem to 2000. After i moded with one bios i couldnt go over 2000. Depends on the mod you did. Remove the oc and start low and raise just a little at a time

1 Like

when i modded the bios i lowered to 2000. Later i’ll try without any mods to see if starts. ty

I modded the bios and it worked without any overclock, but i can go just up to 1750mhz memory clock, 26.5 MH/s. When I put 2000 shows the message GPU dead. It is not working for me

Because the mod is not correct did you use the one click bios mod? Click all ok for all settings save and flash it

As I told you before, i did it with my RX 580 and worked perfectly, but with my RX 570 is not working. I did what you say

Hi, I forgot to reply, I found an old printscreen with the factory BIOS and discovered that my memory is Hynix. Then I got the right BIOS and I did the mod, look the actual performance:

It is very stable and with good performance. Ty for your help

1 Like

You can try with VDD set to 831 instead of 840 and memory clock 2150

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.