Increase your income with Hive. Invite your friends and earn real cryptocurrency!

MSI Micron Radeon RX 580 8 GB "Unknown Memory"

Hi all,

I’ve recently started putting together a new rig. I’ve got one MSI RX 580 8 GB working perfectly and hashing well. I have an identical 2nd MSI RX 580 8 GB that shows up in HiveOS, but shows “Unknown Memory”. It will not mine. Here’s what I’ve tried so far:

  • Downloaded Stock BIOS, One-Click Mod and Flash. The Flash worked, but did not fix the problem. Confirmed during the process that it indeed has Micron VRAM.

  • Tested the Rig with both just the working card and just the non-working card. It boots and works normally with the working card. Gives the same issue with the non-working card.

  • Tested multiple Riser Cards (same behavior).

  • Tested multiple PCI-e Slots (this is a brand new Zotac B150 Mining Board)

  • Booted into a fresh install of Windows and tested with GPUZ. The card shows up and is detected normally. It properly identifies the VRAM.

  • Tried a fresh install of HiveOS (tried both a Flash Drive and a SSD).

  • Made sure that 4G is enabled in BIOS and that all PCI-e lanes are set to PCI-e Gen1.

Do I just have failed VRAM on this card or are there other things that I can check? Thank you in advance for any help!

I ve got literally this same with 5700XT.
But my is seen by windows by microsoft desktop GPU and i cant install drivers.

Did you figure it out?

I’m having the same issue but with 5 rx580s. This really sucks

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.