Increase your income with Hive. Invite your friends and earn real cryptocurrency!

MSI GAMING X TRIO 3080 trouble with HiveOS

Hi there,

I’ve just made a new rig with two 3080 to start, with two MSI RTX 3080 Gaming X TRIO.
But with HiveOS, cards are not going over 89Mhs and 205W no matter overclocking a set.
I tried a lot of OC profile and i tryied also to flash vbios with MSI Surprim, ASUS Tuf or Strix, EVGA FTW. Each time i can’t get more than 89Mh/s.
Some research on internet shows that some people have the same problem but it is fixed with Suprim vbios on windows, but not on hiveos.

Here is a screen of my HiveOs (First Watt is fake i don’t know why perharps vbios is messing with)


Exactly the same bug here, I’ve also opened a post, and there are several others.

“nvidia-smi -q” doesn’t show any type of limiting of throttling, so it’s not a temperature issue.

We’re all really stuck with gaming x trio cards :expressionless: and I think that hive devs aren’t even aware of this, its a specific card’s problem, so, MSI should fix this in a new vbios :expressionless:
honestly the problem is not with Hive itself, but instead with the nvidiadrivers in linux or with the card’s vbios because you can use nvidia-smi to check the limiting values and the OS is doing it right. The card is just not using enough power :frowning:

Hi everyone,

This is my first post here, i thought it could help someone.

I can confirm that i have tried the following BIOS on the MSI RTX 3080 Gaming X Trio.

  1. MSI Suprim X
  2. Gigabyte Aorus Xtreme
  3. EVGA FTW3 Ultra

Below are my findings.

The MSI Suprim X is a good bios with correct reporting however it does not change anything under HiveOS. The best i could do with it was to rech 89.xx MH with -700 on the core and +700 on the memory power draw was around 215watts.
On Windows you can get 104.xxMH by setting 112% on power and +160 on the core and 1500 on the memory was drawing 235 wats of power.

The Aorus Xtreme was working good enough on Hive OS with power draw around 335 reported and 103.x MH with 3000 on the memory clock and 1400 set on the core.
I can confirm that the total power draw of the system with 2x RTX 3070 and 1x 3080 from wall was 525wats which i measured external so this is to confirm that power reporting was not correct.
My 2x RTX 3070 was running at 122 and 113 watts which makes it 235 considering the power draw in windows for the 3080 was 235, that takes i to 470 and the leads to a difference of 55 from the actual power draw from wall which is what the rest of the system would use for operation.

Now i have almost the same result for the EVGA FTW3 Ultra bios but abit lower on hashrate 102.x MH and power draw reported as 315 watts but the actual power draw from the wall was 525watts.

attach is screenshot from the rig.

Hope this helps!

1 Like

This is very helpful. I have not been able to successfully flash the bios to anything except the Gaming X version even when I click the “force flashing” button. It just crashes the system. Thankfully, it comes back up with the previous bios. TIA

I have had the same problem, i had to boot into windows and flash it from there.

Thanks for the response. Do I just use NVFlash and file name? Anything else I need to be aware of?

There are plenty of tutorials on this one but have a read through the following.

Basically you just need to disable protection before you flash, to force is you need to nvflash -6 …

Just be careful because if it goes wrong you can loose you card for ever!

Did you manage to get this flashed on Hive OS?
Thank you

No didn’t work on hiveOS for me, had to do it in windows.

I flash bios on hive with nvflash, it works.
Refer to this post:

Hi! I’ve started mining very recently and I’m new to all this. I have a question for you. Can the process of flashing a different BIOS be done with the “Flash VBIOS” button in the Overclocking tab of my worker (image below) or do I have to use NVFlash for this purpose?



I haven’t been able to flash a different bios with HiveOS, somehow it disconnects my rig when it attempted to flash it.
I used windows and nvflash for it.

Hope this helps.

But you should be able to do it this way, right? I mean it shouldn’t cause any problems if done correctly.

Depends on the definition of right, but there is always a risk when flashing a different bios. for me it didn’t work. You can give it a go and see if it flashes a different bios for you but that is something for you assess the risks.

Ideally it works as i have flashed bios with it but it was for the same card not a different one.

Just my two cents worth… tried to flash my MSI Gaming Trio Z via HIVEOS but it didn’t work. It’s a recent version of HiveOS. I tried it again, same result no change in bios card after the rig reboots. I then tried using Windows (with the ASUS Strix Driver) and bingo it updated the bios successfully. Now in HiveOS my card is hashing 100.7MHs using (fan: 70%; core: 1070; mem: 2500). Temp is 52 degrees mining for a day already and very stable no throttling. I didn’t try flashing the SuprimX bios, if I get some time I will do that another day and report back. I prefer the card to be known as “MSI” not “ASUS” in my Hive Farm. One of the disadvantages I guess but for the extra hash rate I can live with it. Thanks all.


merhaba melek bende de x trio var acaba hangi biosu atacağım birde uzaktan yardım edermisiniz ?

Yiasou!!! :smiley:

Take look on YouTube how to flash bios. I like this video… How To Flash Nvidia RTX 3080 Trio BIOS To Asus Strix for a higher Hashrate or better FPS - YouTube

Then download and use the ASUS Strix bios. Check the version on the video and download the same. Its the version from 2020 - not 2021. Make sure you follow the flashing instructions exactly. Reboot into HiveOs and you will see the card as ASUS not as MSI. Set clocks to… absolute core 1070, memory 2500, fan 70% - you will get 100.5MHs on ETH.


1 Like

Heya there,

I have 3x MSI 3080 Gaming Z Trio on my rig. My max hashrate is at 91 for one card. then the 2nd is on 89 to 90. then the 3rd one is playing around 88 to 89. Still not flashing it to other bios. I seem to get a max of 91 hashrate at a low OC. -200 / 750 and it’s working just fine. But if I bump it up. the hashrate goes down to 85 to 87.

That is exactly the same ting I saw. as I moved to ever higher OC setting the hashrate went down. At first I thought I needed to quit drinking but its a fact. I have two of the same cards.

Yeah, This GPU is kinda frustrating unlike other brands of 3080s that can hit 95 to 101mhs real quick. Only solution is to flash bios in it then at the same time change the crappy thermals in it and I don’t have the time to do that. :smile: