Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Monero all shares rejected [SOLVED]

first boot of hive os 8 xfx rx 480 gtr 8g gpus. tried 4 different pools. with the same results. i mined cryptonight pool for hours with both XMR-Stak and xmrig and no valid shares all shares rejected. changed monero to monero7 in configure miner profile for xmr-stake. just to get it to mine at all. i get hash rates. but no valid shares. reported both by hive and the pools them selves by my wallet address. cryptonight pool reported last share 5 hours ago. that would have been when i started hive for the first time with just one gpu switched to eth and its minning fine 100% good shares what do you have to do to get monero working.??

We are a lot of people here with the same problem, it is strange that a guide is not online yet.

1 Like

I have tested few days ago xmrig-amd with algo cryptonight and variant monero8 and it was working just fine on hiveon pool.

1 Like


Could you please post all your settings, how to configure the miner and pool?

1 Like

yes can someone please post thire working settings or help us get this working any information i found in English is either outdated or in Russian and most likely outdated

Wallet - this one you should know how to do it… unless you want me to give you my address :slight_smile:

Flight sheet [email protected]:
{“name”:“[email protected] (xmrig-amd)”,“isFavorite”:false,“items”:[{“coin”:“XMR”,“pool”:“hiveon”,“pool_geo”:[“Europe (Rigs)”],“pool_urls”:[“”],“wal_id”:7654321,“miner”:“custom”,“miner_alt”:“xmrig-amd”,“miner_config”:{“url”:"%URL%",“algo”:“cryptonight”,“pass”:“x”,“miner”:“xmrig-amd”,“template”:"%WAL%.%WORKER_NAME%",“install_url”:“",“user_config”:"--k --donate-level 3 --opencl-platform AMD --opencl-devices 0,0,1,1,2,2,3,3,4,4,5,5 --opencl-launch 496x8”}}]}

Flight Sheet [email protected]:
{“name”:“[email protected] (xmrig-amd)”,“isFavorite”:false,“items”:[{“coin”:“Nicehash-CryptoNightV8”,“pool”:“nicehash”,“pool_geo”:[“Europe”],“pool_urls”:[“”],“wal_id”:1234567,“miner”:“custom”,“miner_alt”:“xmrig-amd”,“miner_config”:{“url”:"%URL%",“algo”:“cryptonight”,“pass”:“x”,“miner”:“xmrig-amd”,“template”:"%WAL%.%WORKER_NAME%",“install_url”:“",“user_config”:"--variant monero8 --k --donate-level=3 --opencl-platform AMD --opencl-devices=0,0,1,1,2,2,3,3,4,4,5,5 --opencl-launch=496x8”}}]}

If you go with importing this - you need to edit Flight sheet and select correct wallet.

1 Like


So this it to different flightsheets?

I only need to use the first if i want to mine Monero?

Right on…

Hi again

So i am not to good at this, where do i paste all that information?

is this how i do the custom miner you posted i tried to import it but no jason file in tar.gz i download amd-xmrig2.8.4 from farm downloads is this the same miner you posted


I have it like this:

1 Like

still cant get it to work

allready fixed the typo saw it when i uploaded the pic still get ./xmrig-amd: unsupported non-option argument ‘1’

first thank you for helping so much last thing that failed after i fixed typo is

Selected OpenCL device index 4 doesn’t exist.

[2018-11-07 10:09:47] Failed to start threads.

i have 4 cards in now so it should be 0-3 like this?
–opencl-devices 0,0,1,1,2,2,3,3,

yes… also, if your cards have 8GB RAM then you can go higher with intensity… then you can put --opencl-launch 1000x8 or any other number for fine tuning…

1 Like

its working thank you so much!!!

so i have one more question when i go to hiveon monero pool i dont see my worker conected or see and stats i added my wallet in flight sheet do i need to change it somewrere else minner is minning and pinged the addresss from minner logs … can i change pools with this setup without breaking the miner?


PING ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=42 time=167 ms
64 bytes from ( icmp_seq=2 ttl=42 time=169 ms
64 bytes from ( icmp_seq=3 ttl=42 time=173 ms
64 bytes from ( icmp_seq=4 ttl=42 time=163 ms
64 bytes from ( icmp_seq=5 ttl=42 time=161 ms
64 bytes from ( icmp_seq=6 ttl=42 time=160 ms
64 bytes from ( icmp_seq=7 ttl=42 time=159 ms
64 bytes from ( icmp_seq=8 ttl=42 time=158 ms
64 bytes from ( icmp_seq=9 ttl=42 time=156 ms
64 bytes from ( icmp_seq=10 ttl=42 time=165 ms
64 bytes from ( icmp_seq=11 ttl=42 time=164 ms
^C ping statistics —
11 packets transmitted, 11 received, 0% packet loss, time 10011ms
rtt min/avg/max/mdev = 156.365/163.680/173.996/5.020 ms

Wait and it will show up… Wait for 30 mins or so…

Of course you can change pools - it works for every CNv8 pool…


thanks again for your help so very much could not have done it without you and yes i see it now when i was mining eth on the hiveon pool it showed up almost immediately so i was a little worried thanks again :+1::+1::+1::+1::+1::+1:

1 Like