Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Mixed AMD Kaspa rig efficiency and worker command

Hi all, this is my rig, I’m currently mining Kaspa and I’m using this command which drastically reduces power consumption “echo 0 > /sys/bus/pci/devices/0000:06:00.0/pp_dpm_mclk && echo 0 > /sys /bus/pci/devices/0000:09:00.0/pp_dpm_mclk && echo 0 > /sys/bus/pci/devices/0000:0c:00.0/pp_dpm_mclk && echo 0 > /sys/bus/pci/devices/0000:10 :00.0/pp_dpm_mclk && echo 0 > /sys/bus/pci/devices/0000:13:00.0/pp_dpm_mclk && echo 0 > /sys/bus/pci/devices/0000:16:00.0/pp_dpm_mclk && echo 0 > /sys /bus/pci/devices/0000:19:00.0/pp_dpm_mclk && echo 0 > /sys/bus/pci/devices/0000:1d:00.0/pp_dpm_mclk && echo 0 > /sys/bus/pci/devices/0000:20 :00.0/pp_dpm_mclk && echo 0 > /sys/bus/pci/devices/0000:23:00.0/pp_dpm_mclk”

The rig draws about 930/940w at the wall. Since I don’t use photovoltaics, therefore about 12/14 hours a day, I wanted to know if it was possible to execute this command when starting the rig, since the command is reset at each restart. Would it be possible to do this? Thank you

no need for all that, just change your memory clock to 1 instead of 1000.

Oh great! So without activating the command, I set all the GPUs to 1 on the memories and I’m fine. I’ll try it right away, thank you very much

I tried putting 1 on all GPUs. Consumption drops compared to having nothing, but increases by about 140w at the wall, compared to the command. By putting 1 on the memories, could I also lower their voltages? Sure I leave 1, because instead of 1140w it consumes 1078/1080, with the command I go down to 930/940w

Post the new worker interface data and then Miner interface data to confirm memory is at lowest state.


Anyone one seems to be running any 5600xt on Kaspa. I flashed the card using tried OC settings but nothing changed still running Bzminer about to try TeamRedMiner

Hello, this is the data of the miner with the memories set to 1. At the wall it draws 1075w and produces 4820mh/s

This however is with the command entered. At the wall it draws about 940w and produces 4788mh/s

Look at your MCLK in the top vs. the bottom picture, 675 vs. 96 is the where your power consumption is being lost.

As Keaton shared on the very first reply this is all you need to do vs. that scripting command:

It would look like this in action:

Has been available since Dec 2022:

Thanks for the reply. Yes, but the photo with 675 is with memories at 1 without the command, while 96 is with the command inserted. In fact, the watts on the wall are 1075 without command and 940 with command. is it possible to have MCLK 96 without the command? Because if I put 1 the memories are at 675 and not at 96. Even in the photo you posted it says to set the memories to 1 to make them go to 96mhz, but they go to 675 for me, where am I wrong? :sweat_smile:

If the memory clock is not at the lowest state when using the (1) in the correct placement, you have a different issue going on here.

Post your overclocking settings and full view of your software versions likes this:

You are running software from Sept 2022 and the feature was added in…wait for it in Dec 2022:


Then I have to update :sweat_smile:Thank you

1 Like

Outstanding! This works for my RX 5700 and RX 5700 XT running on TeamRedMiner. Changing the memory down to 1 cut about 20w usage off each card. It has been running stable for over 10 hours now. Thank you.