Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Mining rig shows gpus but only 1 of 4 is hashing, please help!

Set up my first rig yesterday using 4 “pradeon” rx580 8gbs. They all run and show up on hive os but have had a huge problem figuring out how to get all of them mining.

Only the one is mining every time I try anything like switching flight sheets or switching wiring around. I even replaced the gpu with one that was mining on my computer and still shows N/A hash rate for that card as well. I also tried going to the beta version of hive os which I am currently still in btw.
Really confused here so hopefully I can find some help, thanks.


Not sure if you’re still having issues but the first thing you should do is update to the latest version of HiveOS. There generally isn’t a reason to be on the beta version. If it’s still not working, then we can look into some other ways to troubleshoot your problem :slight_smile:

ended up fixing the problem by flashing the bios of the non working one with the bios of the one working GPU and it fixed my problem. although now I am getting an error after mining for a few hours - Autofan: GPU temperature 511 is unreal, driver error. if you know a fix for this it would be great

511/unreal temp error is a GPU error, more precisely, it’s a power disconnection malfunction, in which the software attempts to query the GPU and gets either nothing or invalid data returned.
This is generally caused by a bad riser/cable(s).
Ensure to check your cables (including power & if you’re using them - sata, too).

You were right! I left one of my risers unlocked and that was causing the problem I’m pretty sure because I locked it before bed and its been going ever since with no error. Thanks for the help, google was no help when searching up that error.

1 Like

Hey I got around to building another rig and after two days of steady mining I get the error “GPU driver error, no temps”. Hopefully you have some knowledge of this as well, I’d really appreciate the help

Check PCIe Gen2/Gen3, risers / cables, and your overclocks.

I keep learning the hard way that if something is not clipped in right it will cause errors. Like last time the miner was going for two days so I didnt think it was the problem. Either way theres a broken clip on one of my psus 8pin plugins and I think it was causing the error. only up for 10 minutes so far lol so hopefully all is well now

so it didnt end up fixing the problem and im retracing my steps again. for some reason I keep running into a problem with my second card. ive tried switching everything and haven’t tried doing any overclocking so its very odd. By switching everything I mean everything from the card itself to the riser, sata cable and pcie cable. not really sure what else I could try at this point.

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.