More
referral
Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Lolminer looking for GLIBC_2.25 but not found

Hi there,
I’m running the latest Hive OS version [email protected] and am trying to start lolminer. It won’t start because of the following error:

lolMiner: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.25' not found (required by lolMiner)

Running ldd --version, I see the latest it has is 2.23.

Is there a recommended command to add the missing Glibc version? Am I doing something wrong to get lolminer to run correctly?

Same issue with me. Are there LHR cards in your rig?

Yeah I have a few. Could it be linked?

Could be, I will try to start it without the lhr card.

To circle back, removing cards didn’t fix it. I had to run:

hive-replace --list 1 yes

This replaces the HiveOS with a full image download instead of the incremental ones from the UI. All my settings were saved so it continued mining after the process completed.

Thank you for posting this fix! I was being forced to update to a newer version of my miner and was getting this error and had no idea what to do to fix it when I was trying to do so earlier today. Impeccable timing that you posted this between then and now! THANK YOU!

1 Like

I am getting the same error message for lolminer and NBminer so I tried the hive-replace command and I get the error message "E: Package ‘fdisk’ has no installation candidate Failed to install required packages" and it boots me out of the hive-replace wizard. so thats fun.