Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Issues with Linux Kernel 5700xt, 3060ti, 3070

Alright, it took me a minute to figure out what was happening, but I think I got there.

Recently I started up a new rig. It was 6x 3060ti. I had to get another ssd with HiveOS on it. I used the same file I’ve been using since I started and the Hive version is 195 on the file. After getting the rig running, none of the 3060ti were recognized. They all said “GA 104 [RTX 3060 ti]”
As the card and would not mine. Reading through the forums I came across this post

Which helped describe the issue. I had actually used this post to solve some other 30 series card issues in the past

However, I was unable to do this for the new rig because of my linux kernel. When I attempted to set the nvidia driver to 455.45.01 I would get the following error:

So the driver would never update and I was unable to get the cards running. That’s when I decided I would just switch the SSD with another one of my rigs that I knew had a lower kernel. I had a 3070 rig running on 5.4 and another 5700xt rig also running on 5.4
Not wanting to risk the 3070 rig having the same issue, I switched it with the 5700xt rig and it starting running just fine, without even updating the drivers.

Notice the driver and kernel versions

Then I put the new kernel on my 5700xt rig, and it BROKE!!! The cards all got detected but NONE of them would mine.

The hash rates are all 0. I struggled with this for a long time, trying many many things. In the end I decided to change the tuning settings I had set up for this rig. I cleared out all my extra miner configs and tuning, because I was forcing --eth_config=B on the rig previously. This solved the issue on GPU 0

The one thing from this photo you can see is that, all the cards trying to tune in B mode were screwed, and the one card trying to tune in A was working. So I added the --eth_config=A to the rig and tada!!

Everything is working fine now

This problem I ran into is bringing up a concern that I am hoping some others here can help me figure out.
Is there anything that can be done about this? I want to build at least one more rig, full of 3070 cards, but if I can’t get the right linux version, or hive version, or driver, or some combination of the 3 then it’s kinda pointless to try. If anyone knows of a way to get hiveos img on an SSD without the 5.10 linux kernel please reply here.
Follow up, does anyone have any evidence of a working B mode 5700xt on this kernel?

Thanks for any updates and upvotes :slight_smile: Hope this helps out someone


Just want to say a huge thankyou for this post. It helped me a lot at a time when frustration was about to get the better of me.
Thanks again.

1 Like

You’re welcome!! This one was a doozy, glad it could help somebody!

(shameless plug - ETH address: 0x270DD5948AA4a20B3783CE3312B907451F79D23d ) :slight_smile:

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.