Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Invalid shares - trex & nvidia

Started getting invalid shares last night. At first I thought it might be due to the memory overclocks, but then I noticed that one of the cards (ASUS 3080) does’t have any OC at all, just an absolute core settings and high fan.

I also noticed that invalid shares started popping up on 2 of my rigs last night, ruling out perhaps it being an issue specific to 1 rig. Rig 3 (no screenshot posted) which is connected to the same network switch has no invalid shares. What could be the possible causes of these invalids, especially on the card that has no OC set?

1 Like

Try the following overclocking for 3070 cards.
core 1100
mem 2400
pl 0

That would increase the OC on the 3070s. Since i’m getting invalid shares, wouldn’t I want to do the opposite?

Started having the same problem after updating to 0.6-203@210531 yesterday afternoon (Using T-Rex with ethash algorithm). Nothing else has been modified other than this system upgrade and this has not been a problem before - but now, after the upgrade, we are back to the same problem we had a couple of versions ago.

Even tried decreasing the OC a bit - but this didn’t help.

I think there is something with this specific implementation when it comes to T-Rex.

I will try downgrading to the previous version to check what’s going on.

1 Like

Update the driver helped me:)

1 Like

…but I’ve also noticed that my nvidia drivers were outdated - so, for now, I’ve run the nvidia-driver-update in Hive Shell window, which updated those - so I will monitor the situation and see if it changed anything (apparently, downgrading Hive OS version manually is a bit more of a pain). Hopefully, it was just that and invalid shares issue will get resolved. One interesting (positive) side effect after nvidia driver update is that the rig is slightly more efficient, with ~10w less power consumption - so I’m keeping my fingers crossed :slight_smile:


After updating to nvidia driver 465, temps and power usage did go down but my real time hash rate has dropped almost 250MH/s! I’d almost prefer invalid shares to such a big drop in hash power… has anyone noticed similar hashrate drops with nvidia driver v465?

Let it work for a bit - after upgrade and reboot the hashrates need time to catch up. You can only judge this after at least 10-15 minutes

1 Like

Thanks Teymur, hashrate has increased back to the average. I’ll keep an eye on invalid shares over the next few days to see if the driver update resolved the issue.

Mine came back :frowning:

Before anyone comments on high OC values - these same ones worked for a few weeks with no issues. Rejected shares only appeared after the recent OS upgrade

lolminer is giving invalid shares here with rx580(hynix) and nvidia 1080

noticed same thing that they started appearing after that update

I am also still getting invalid shares, even on cards that have no memory overclock!

Yeah, mine are getting out of hand.

I guess there is no way around downgrading the OS version :frowning:

Last stable version ( 5.4.0-hiveos #108, 0.6-203@210403

Interestingly, this version 0.6-203@210403 does not appear in the list of available versions for downgrade - I downgraded to 0.6-203@210401 instead - but the problem doesn’t seem to have been solved.


how would one go about downgrading to a version that is not in the list and, thus, the downgrade cannot just be run with a click of a button?


Update the driver

My drivers were already the latest (465… If you meant “downgrade” the driver - I did now downgrade it to the latest “stable” version 460.80. But I’m still not seeing the version you mentioned in the list of OS versions available for downgrade. Still the same list.

Oh, I had a similar problem.
After updating to the latest version of hiveos, invalid share started to appear.
I updated the nvidia driver to version 465.31, and also tested the trex versions 0.20.3 and 0.20.4.
But there are still invalid shares.

At first I thought the problem was overclocking and I said change the overclock. But now I know the problem arises after updating hiveos.

I will now try the stable version 0.6-203@210403 and announce the result.

You can with the command
hive-replace -y --stable

Reduce to this version

I’m trying this as well, will report back.