More
referral
Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Instructions to bios mod RX 5700 XT on Hive OS

I received an ASRock RX 5700 XT Challenger yesterday (yes, I now know they are crappy cards) and spent hours trying to find succinct instructions on how to mod the bios for overclocking. For my RX 570/580 it was so easy to just download the vBios, upload it to PolarisBiosEditor, and apply the “1-click patch” timings.

For the RX 5700 cards,
(1) go to the overclocking tab and download the vBios.

(2) Download and install “Red BIOS Editor” from this site (scroll to the bottom for the download section): RED BIOS EDITOR and MorePowerTool for Polaris, Navi and Big Navi | Page 3 | igor´sLAB

(2) Open the bios in “Red BIOS Editor”, go to the “VRAM Timings” tab, and copy the value in the 1500 MHz entry (or 1550 MHz if you have that). Then paste that value into all the higher MHz entries. If you have two different memory types (available as a dropdown at the top of the “VRAM Timings” tab), then you have to do this for both memory types. Save the new bios.
I found this video extremely helpful: How To BIOS Mod RX 5700 XT For Crypto Mining 𝐔𝐏𝐃𝐀𝐓𝐄𝐃 𝐀𝐮𝐠𝐮𝐬𝐭 𝟐𝟎𝟐𝟎 - YouTube . Just ignore the initial few steps where he downloads the bios, as you’ve already done that through HiveOS. Follow the steps using Red BIOS Editor.

(3) Use the HiveOS overclock tool to flash the card with the new bios.

That’s it! It’s really simple, but when I searched online I only found all sorts of complicated answers, suggestions to use a bios designed for another manufacturer’s card, warnings about bricking cards, etc, etc. A short post like this would have helped me a ton, hopefully it helps someone else out there.

My hashrate jumped by 3.5 MH/s after flashing the bios, so I highly recommend it!

11 Likes

Hey, thanks for your post.

What was your hasrate before flashing the bios ?

Before flashing I was stable at 52 MH/s (could push it to 54 but got invalid shares). Now I’m stable at 55.5 MH/s.

Muchas gracias por tu ayuda, se agradece que haya compartido.

Nice job. And what about your Watt ?

Didn’t change much, running about 130 W before and after flashing. But it’s bad card. I have an XFX RX 5700 XT, same settings, same hash rate, running at 98 W. With some tweaking I could probably get them both a little lower, but I’m happy with those numbers for now.

can you share your OC settings as well?

Could someone pass the OC that is using the AsRock 5700 xt Micron?

Mine is like this today, but I’m finding the fan too high for the memory temperature

can you share your OC settings as well?

Thank you @pskunk

Your instructions worked like a dream :pray:

1 Like

I bios modded my 5700xt for mining. I flashed the GPU on my pc and the mobo has only 1 PCIe slot. The problem is that right now the 5700xt works only on the slot 1 (GPU 0) of my mining rig (ASRock H510 Pro BTC+). How can I fix that? Should I try flashing the bios directly in the HiveOS? I get weird things happening when I connect the GPU to another slot… The bios freezes right on start, no keyboard light (if the gpu isn’t on slot 1). I can only boot into the bios if I enable CSM without the GPU plugged in… (?) I edited the bios using Red Bios Editor and amdvbflash to save the stock bios and flash it to the card.I used this command:

amdvbflash -p 0 bios.rom (position 0)

I think the GPU is set to only work on GPU 0 position (slot 1). I made everything right! The GPU got from 50mh/s to 55-57mh/s stable, consuming less power! The only problem is the GPU is working only on the first slot off my mining rig. I flashed the stock bios to see if the problem persists, and yes, it does.

Can someone help me?

Two questions: Why is it a problem that the card only work in the first position of the mining motherboard? I agree that it’s weird and indicates some underlying problem, but if it works then I would say just go with it.
Also, why did you flash on your PC instead of directly through HiveOS? I would recommend doing everything through HiveOS. Have you tried reverting the flash on the PC, then moving the card to the mining rig and re-flashing there?
Sorry I can’t be of much more help, there is definitely something strange going on.

I flashed on my PC because I’ve seen a lot of people saying that the 5700xt needs to be flashed on Windows… Can I flash the BIOS of the 5700xt on the HiveOS without problem? I think that will solve the issue. I’m a little scared rn haha, don’t want to brick the most expensive gpu of my rig.

I flashed the bios directly in HiveOS and same problem hahah, but it’s working fine on slot 1 at least… I think it’s recommended to have the nvidia in the first slot, but it’s stable this way right now.

I flashed mine directly in HiveOS. It’s strange that didn’t fix the issue for you, but at least you can mine with it.