Increase your income with Hive. Invite your friends and earn real cryptocurrency!

Installing Chia-blockchain or other GUI programs on HiveOS

Anyone familiar with opening regular gui programs on HiveOS with lower user privileges?

I don’t expect HiveOS to suddenly support Chia, but I just have some general questions about running programs on Linux. Roxterm lets me install Linux packages and I was able to get Nautilus gui file browser and the chia-blockchain gui program installed, but I’ve been having issues actually opening Chia as roxterm is set up to always use elevated privileges which some gui programs don’t allow. I tried to login to the user account with the password listed under the settings tab for my worker but I don’t think that applied correctly or it’s different from the user login password. I also tried creating a new account with useradd (Should I have used adduser?), but that failed to open it either because only one user can display gui programs at a time or I didn’t set up the account correctly. Specifically when I tried to run the program in a new user account I got electron errors which either means the user account didn’t have the filepaths for appdata configured correctly or just a general issue with opening a gui while the HiveOS default User is using the only user desktop. I also doublechecked and all the dependencies for chia-blockchain seem to be installed already.

Is there anything missing in HiveOS from common Linux distributions like Ubuntu or Debian that’s stopping me, or am I just doing it wrong?

I followed this path here and got almost the same problem. I tried again and still having problems with nodes and npm compatibility:

What was the sequence that got you here? I think that I’m doing something wrong

Yeah I just followed that guide earlier today, and got to the same curl error. There are several different versions and derivatives of libcurl that can be added with a package installer. I would assume the higher version numbers would be the best choice, but I don’t know if they would use the same command arguments. I’m only going to use hiveos for a harvester, so I think the cli is fine.

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.