Increase your income with Hive. Invite your friends and earn real cryptocurrency!

How To Hide AMD APU (Ryzen 5 2400G) From HiveOS?

I have a mining rig with a Ryzen 5 2400G, which includes a Radeon Vega iGPU. I disabled the iGPU in BIOS because it caused stability problems, but it still appears in HiveOS as a disabled GPU - meaning I get warnings and messages about a GPU being offline when I’m monitoring my farm, even though it’s not a GPU and it’s supposed to be disabled.

Is there any way to remove it from my rig in HiveOS? Or at least hide it in the web interface, so I don’t have a false warning every time I log in, which makes real warnings harder to spot?

That error is not due to the igpu, it’s typically due to poor ocs on the gpus.

Sorry, I worded that poorly. When I say “error” I mean, for example, the empty “Attention Required” square icon on the farm page. GPUs working normally are green, the disabled iGPU is orange. It also shows up in the GPU count (that I have 1 GPU that needs attention) and in the rig count - everything is working correctly, except HiveOS is reporting the disabled iGPU as offline/crashed, so the rig doesn’t show up as running normally.

Here’s a picture of my farm page. The orange square is the iGPU, even though HiveOS recognizes and lists it as disabled, it still shows up as a “down” GPU:

Are you on the latest stable image/kernel?

Yes, I am on the latest HiveOS version. To be clear, this is not an error or a bug in HiveOS. It is (correctly) showing an inactive GPU as being inactive, and giving a warning for it. The problem is that HiveOS considers iGPUs in Ryzen processors the same as regular GPUs, when those iGPUs should not be considered for mining. And I haven’t found any way to hide them so you don’t have a constant warning on your rig, which hides other (actually useful) warnings; you have to go completely down to the rig page to check if anything is wrong, instead of just quickly glancing at your farm page.

What kernel are you on?

5.10.0-hiveos #110, I installed HiveOS on this rig about a week ago.

have you tried specifying which gpus to use to teamredminer, leaving off the apu?

can you show a screenshot of your worker overview screen?

That worked, thank you! Specifying which GPUs to use in the miner configuration (inside the flight sheet, ie “–devices 0, 2, 3”) makes HiveOS basically ignore the disabled APU (or GPU). Rather than showing the orange warning box or having a warning on the rig in the farm screen, it shows the ignored/disabled GPU as green and functioning normally with no warnings.

Edit: wait nope, I didn’t refresh the page. It didn’t work. Well, sort of. The disabled GPU shows green on the individual worker screen (which is what it should do), but the farm screen lists a warning (orange) on the number of workers and an error (red) on the number GPUs - one offline, the disabled GPU.

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.