Increase your income with Hive. Invite your friends and earn real cryptocurrency!

HiveOS won't boot with 7th card?

I’ve tried to change the PCIE lanes, different risers, different cables, etc.

I can get HiveOS to boot normally with 6 cards or under but when I plug in a 7th card it throws up

“error: can’t allocate initrd”

It’ll just pause and reset after that on loop.

I’ve tested the cards individually, risers individually, cables, etc. Everyone works as long as a 7th card isn’t plugged in.

CPU: 3200g Mobo: Asus x570-P Ram: 16gb 3200 16cl

Anyone have any ideas?


Having the same issue, which pci express splitter are you using?

CPU 3200g MB Gigabyte x570 Ram 8GB

Same issue here with 7th card and PCIe splitter.

Ok so I managed to get it work by doing the following changes in bios:

Above 4G Encoding: Enabled
CSM: Disabled

I also disabled HD onboard audio to free up allocatable memory addresses. Not sure it really helped but I’ve read somewhere that you should disable all the devices, controllers and ports you don’t use.

Please note that first time I’ve changed these bios settings the 7th card did not get recognized but at least HiveOS was able to start. After a manual reboot it just showed up, then on a third reboot it lost again. Again a reboot helped and I’m mining happy now with 7 card.

Not sure how permanent is this because as you can see the 7th card gets recognized on every second boot so far. I may need further tweaks.

Hope it helps some of you!

MOBO: Gigabyte X570 Aorus Pro with 4 port PCIe express splitter in the bottom slot.


Thanks so much! I was having this same issue with my RTX 3080 Ti and I was just getting ready to swap out the motherboard but this solved my issue!

This worked thank you so much!!!

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.