Increase your income with Hive. Invite your friends and earn real cryptocurrency!

HiveOS support MSI H310-F Pro?

HiveOS support MSI H310-F Pro, with Intel H310 chipset?
Any experience?

I have this board. I’m having a nightmare getting HiveOS to boot fully on it. I can boot win64 and ubuntu without problem.

if you try start with pendrive you must disable windows drm(or something like this), mining mode off, and next you must turn on 4g mode and all pcie on gen 1 or 2.

I’ve tried this but still hangs during hiveos boot, I’m using RX470s.
Can you save your working settings to a usb (it’s in OC profile in bios) and share them please?

Unfortunately, I currently do not have access to the bios. Send screenshots / screen photos with booting, screen with PCI-e settings. Did you turn off the Mining mode or did you activate 4g? Additional power supplies are connected?

Try to flash newest motherboard bios and then disable Windows 10 WHQL support on bios setting
I’m using H310-F pro mining for 4-5 weeks already. Three of RX 470 8G 12 and two P10412.

[quote=“UhuttMe;5081”]Try to flash newest motherboard bios and then disable Windows 10 WHQL support on bios setting
I’m using H310-F pro mining for 4-5 weeks already. Three of RX 470 8G 12 and two P10412.[/quote]

Done and done already. Still can’t get it to boot all the way. It’s definitely to do with the nvidia cards/drivers because it boots without any, but hangs during Ubuntu startup with one or more connected. Cards are Asus Strix RX 570s. If you’re running H310-F successfully, can you save your bios settings to a USB and upload (the bios supports saving to USB if you format the USB with FAT32)?

Thanks in advance!

If I connect a monitor I can see the error being output (photo attached)

I have 6 cards and I have tried different cards, risers, a range of suggested bios settings, no luck.

Cards are unmodified Asus Strix RX 570s.

try run with 1 card first., do you have GPU on PCIx16 attached?

I have tried a single card of course, using the PCIx16, and tested it (and other cards, and cables, and risers) on all possible variations of slots. No change.

Unmodded RX 570 shown as working on ethos and win10, plugged directly into PCIEx16 slot, with all recommended bios settings from above - same issue.

I can ssh into the box when it hangs. It shows the the amdgpu-pro driver didn’t load and instead of a 25-30mhs hashrate it’s running at 14. The cards are correctly identified. Something about this mobo and these Strictly RX 570 cards with HiveOS just doesn’t work.

Running on Windows, using HiveOS for Windows Beta it works fine, however the Windows Beta is still missing key features like remote miner restart & system reboot. Would really like to get the Ubuntu version working. Any ideas anyone?

are you use ssd or pendrive?

But that’s not all. I miss something. I make theese things and after exiting BIOS even the MSI Logo does’nt appear. I make them to gen 2. With gen 1 is the same problem.
Can you tell me what mode on boot you give - LEGACY+UEFI or only UEFI? What else?

1 Like

I am in the same situation.

I disabled Windows 10 WHQL support in the BIOS setting.

The Hive logo mark was displayed, but after that the error indication continued.

I dont have the same Mobo , but i have same issues with my rig. and i even re-flashed hiveos ssd with the latest. and my last solution was connecting 1 nvidia or onboard GPU , set rigID and Password , then i remove it and re-plug amd cards and manage it remotely only without using screen

1 Like


I have my BIOS on motherboard MSI H310-F PRO that boot and boot on my USB 3.0 16GB to launch HIVEOS without problems with 4 GPU (3x RX580 and 1x RX570). But as soon as I add one or my two remaining cards (RX570) my BIOS does not want to start.
Has someone already had this problem ?
I updated my BIOS on my motherboard, changed the settings by activating the 4G option but still the same problem.
In the meantime, thank you for your help.

1 Like

I have an error message see picture