Increase your income with Hive. Invite your friends and earn real cryptocurrency!

HiveOS noob looking for guidance with errors on first rig

I’ve been mining with ASIC’s for a few years now. and I recently decided to try and build my own GPU rig. I got everything working well when I tried with 1st GPU (GTX 1070). The GPU was mining and I saw a steady has rate. The moment I added the 2nd GPU (RTX 3060) - i get these errors below.

  1. Unable to enum CUDA GPUs: invalid device ordinal
  2. No Available GPUs for mining. Please check your drivers and/or hardware.

HiveOS is running on a USB stick (16gb) - I did a forceupdate on bios (through HiveOS dashboard), update drivers (with a command line in the miner) and removed all overclocking settings (through HiveOS dashboard). The two GPUs are connected with risers. My motherboard is z170a Asrock - 750watt power supply by EVGA - i3-7100 processor and 8gb ram. For Ethermine, I tried using Phoenixminer & lolminer. I also tried gminer under Hiveon

I haven’t done any changes when adding the 2nd GPU aside from connecting it to the risers and power supply. I’m stuck at this point and hoping someone here can give me guidance or put me in a direction at least.

Any suggestions are greatly appreciated too!

Have you changed bios settings in the mobo? Pcie speed gens2 and 4g encoding enable?

Thanks for reading!
No i havent. Can you clarify where I can find these in BIOS? PCie speed Gens2 and 4g encoding to be enabled?

Just did this and still same error :frowning:


yeah you said you updated the drivers but whats the current version? if its a new 3060 card , it is LHR newly manufactured and you will need atleast driver 465 to work.

This topic was automatically closed 416 days after the last reply. New replies are no longer allowed.